summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Smith2019-01-27 18:48:51 -0500
committerStephen Smith2019-01-27 18:48:51 -0500
commitdd7528fac3368cacb90d4de347934f1365c0d9a7 (patch)
tree0fae67bb708075c52be0e3f4ce04d1ec5ff8a1ea
parenta2584135de5232fe66aad6d17f153725d1788532 (diff)
downloadaur-dd7528fac3368cacb90d4de347934f1365c0d9a7.tar.gz
Split package to add lua 5.1 and 5.2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD36
2 files changed, 47 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 945dde9cf12a..21c4d9eabbbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 26 19:33:25 UTC 2019
+# Sun Jan 27 23:48:24 UTC 2019
pkgbase = lua-wsapi
pkgdesc = WSAPI is an API that abstracts the web server from Lua web applications.
pkgver = 1.7
@@ -8,13 +8,27 @@ pkgbase = lua-wsapi
arch = i686
arch = x86_64
license = MIT
- makedepends = luarocks
- depends = lua
- depends = lua-luafilesystem
- depends = lua-rings
- depends = lua-coxpcall
source = wsapi-1.7.tar.gz::https://github.com/keplerproject/wsapi/archive/v1.7.tar.gz
md5sums = aacadf9dabeb82b044cb3f1006c5df0d
pkgname = lua-wsapi
+ depends = lua
+ depends = lua-filesystem
+ depends = lua-rings
+ depends = lua-coxpcall
+ depends = luarocks
+
+pkgname = lua51-wsapi
+ depends = lua51
+ depends = lua51-filesystem
+ depends = lua51-rings
+ depends = lua51-coxpcall
+ depends = luarocks5.1
+
+pkgname = lua52-wsapi
+ depends = lua52
+ depends = lua52-filesystem
+ depends = lua52-rings
+ depends = lua52-coxpcall
+ depends = luarocks5.2
diff --git a/PKGBUILD b/PKGBUILD
index 1f784c83228b..f2d830c90626 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Stephen Smith <stephen304@gmail.com>
-pkgname=lua-wsapi
+pkgname=('lua-wsapi' 'lua51-wsapi' 'lua52-wsapi')
+pkgbase=lua-wsapi
_rockname=wsapi
pkgver=1.7
pkgrel=1
@@ -8,18 +9,35 @@ pkgdesc="WSAPI is an API that abstracts the web server from Lua web applications
arch=('i686' 'x86_64')
url="http://keplerproject.github.com/wsapi"
license=('MIT')
-depends=('lua' 'lua-luafilesystem' 'lua-rings' 'lua-coxpcall')
-makedepends=('luarocks')
-conflicts=()
source=("${_rockname}-${pkgver}.tar.gz::https://github.com/keplerproject/${_rockname}/archive/v${pkgver}.tar.gz")
md5sums=('aacadf9dabeb82b044cb3f1006c5df0d')
-build() {
+_package_helper() {
+ _lua_ver=$1
+
+ mkdir -p "$_lua_ver"
cd "$_rockname-$pkgver"
- luarocks make --pack-binary-rock --deps-mode=none "rockspec/$_rockname-$pkgver-1.rockspec"
-}
+ luarocks-${_lua_ver} make --pack-binary-rock --deps-mode=none "rockspec/$_rockname-$pkgver-1.rockspec"
+ mv *.rock ../${_lua_ver}/
-package() {
- luarocks install --tree="$pkgdir/usr/" --deps-mode=none "$_rockname-$pkgver"/*.rock
+ luarocks-${_lua_ver} install --tree="$pkgdir/usr/" --deps-mode=none ../${_lua_ver}/*.rock
find "$pkgdir/usr" -name manifest -delete
}
+
+package_lua51-wsapi() {
+ depends=('lua51' 'lua51-filesystem' 'lua51-rings' 'lua51-coxpcall' 'luarocks5.1')
+
+ _package_helper "5.1"
+}
+
+package_lua52-wsapi() {
+ depends=('lua52' 'lua52-filesystem' 'lua52-rings' 'lua52-coxpcall' 'luarocks5.2')
+
+ _package_helper "5.2"
+}
+
+package_lua-wsapi() {
+ depends=('lua' 'lua-filesystem' 'lua-rings' 'lua-coxpcall' 'luarocks')
+
+ _package_helper "5.3"
+}