summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-05-01 11:54:26 +0300
committerCaleb Maclennan2019-05-01 11:54:26 +0300
commit7627367c774bd99f0ae6d4fea58b12c2ff0cd6fa (patch)
tree6db53173401f6457acf87491e879067e771e5034
downloadaur-7627367c774bd99f0ae6d4fea58b12c2ff0cd6fa.tar.gz
Initial add
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3099e10e94e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lua51-formatter
+ pkgdesc = Beautifies Lua code
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://luarocks.org/modules/luarocks/formatter
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = luarocks
+ depends = lua51
+ depends = lua15-checks
+ depends = lua51-metalua-compiler
+ depends = lua51-penlight
+ source = https://luarocks.org/formatter-0.1.1-1.src.rock
+ sha256sums = 1db31a2d840cc75e3ecbb6ba21d76085c2efaa639b98667c717da2e2d9317a5f
+
+pkgname = lua51-formatter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ad2dba6f200
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=lua51-formatter
+pkgver=0.1.1
+_rockname=formatter
+_rockrel=1
+pkgrel=1
+pkgdesc="Beautifies Lua code"
+arch=('i686' 'x86_64')
+url="https://luarocks.org/modules/luarocks/formatter"
+license=('GPL')
+depends=('lua51' 'lua15-checks' 'lua51-metalua-compiler' 'lua51-penlight')
+makedepends=('luarocks')
+conflicts=()
+source=("https://luarocks.org/${_rockname}-${pkgver}-${_rockrel}.src.rock")
+sha256sums=('1db31a2d840cc75e3ecbb6ba21d76085c2efaa639b98667c717da2e2d9317a5f')
+
+package() {
+ luarocks --lua-version=5.1 --tree="$pkgdir/usr" install --deps-mode=none "${_rockname}-${pkgver}-${_rockrel}.src.rock"
+ find "$pkgdir/usr" -name manifest -delete
+}