summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2018-03-30 10:55:16 +0200
committerosch2018-03-30 10:55:16 +0200
commitc572801fc778eb40c90bb35066133c0b68c81989 (patch)
treeda590a03870ba5e752ef69f69d0ba36e198087e7
downloadaur-c572801fc778eb40c90bb35066133c0b68c81989.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD51
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c98f966b80b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lua51-lanes
+ pkgdesc = A solution for running Lua multithreaded
+ pkgver = 3.11
+ pkgrel = 1
+ url = https://github.com/LuaLanes/lanes
+ arch = x86_64
+ license = MIT
+ depends = lua51
+ source = lua51-lanes-3.11.tar.gz::https://github.com/LuaLanes/lanes/archive/v3.11.tar.gz
+ md5sums = 07ed104a450b76d5919cc8f46a5b4a2f
+
+pkgname = lua51-lanes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..964bb752a0dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: osch <oliver at luced de>
+pkgname=lua51-lanes
+pkgver=3.11
+pkgrel=1
+epoch=
+pkgdesc="A solution for running Lua multithreaded"
+arch=('x86_64')
+url="https://github.com/LuaLanes/lanes"
+license=('MIT')
+groups=()
+depends=('lua51')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/LuaLanes/lanes/archive/v$pkgver.tar.gz")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+prepare() {
+ cd "lanes-$pkgver"
+}
+
+build() {
+ cd "lanes-$pkgver"
+ make LUA=/usr/bin/lua51 \
+ LUA_FLAGS=`pkg-config --cflags lua51` \
+ LUA_LIBS=`pkg-config --libs lua51` \
+ CFLAGS="-O2 -fPIC `pkg-config --cflags lua51`"
+}
+
+package() {
+ cd "lanes-$pkgver"
+
+ install -d "$pkgdir`pkg-config --variable=INSTALL_CMOD lua51`/lanes"
+ install src/lanes/core.so "$pkgdir`pkg-config --variable=INSTALL_CMOD lua51`/lanes/core.so"
+
+ install -d "$pkgdir`pkg-config --variable=INSTALL_LMOD lua51`"
+ install -m644 src/lanes.lua "$pkgdir`pkg-config --variable=INSTALL_LMOD lua51`"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname"
+}
+md5sums=('07ed104a450b76d5919cc8f46a5b4a2f')