summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXabre2019-03-17 13:29:02 +0100
committerXabre2019-03-17 13:29:02 +0100
commit27a40812eee0ebe124ed1d1b3e8a6cef1b01c287 (patch)
treed925c9ec8067bae11dc0ff6ff4a68568cae48dcb
parent2cec6813a47271b339076353bf3e19a38f8c8f29 (diff)
downloadaur-27a40812eee0ebe124ed1d1b3e8a6cef1b01c287.tar.gz
Luarocks dep change
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 896b68f868fb..f31765daa073 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = lua51-lcf
pkgdesc = Lua code formatter (for Lua 5.1)
pkgver = 5.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/martin-eden/lua_code_formatter
arch = i686
arch = x86_64
license = GPL
- makedepends = luarocks5.1
+ makedepends = luarocks
depends = lua51
source = https://luarocks.org/lcf-5.1-2.src.rock
sha256sums = 318af3a5783c696e91ee2e7377b54e16651965ac93b0b71435a9fc7957428cd3
diff --git a/PKGBUILD b/PKGBUILD
index a480c91f102d..7a399461636e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@ pkgname=lua51-lcf
pkgver=5.1
_rockname=lcf
_rockrel=2
-pkgrel=2
+pkgrel=3
pkgdesc="Lua code formatter (for Lua 5.1)"
arch=('i686' 'x86_64')
url="https://github.com/martin-eden/lua_code_formatter"
license=('GPL')
depends=('lua51')
-makedepends=('luarocks5.1')
+makedepends=('luarocks')
conflicts=()
source=("https://luarocks.org/${_rockname}-${pkgver}-${_rockrel}.src.rock")
sha256sums=('318af3a5783c696e91ee2e7377b54e16651965ac93b0b71435a9fc7957428cd3')
package() {
- luarocks-5.1 --tree="$pkgdir/usr" install --deps-mode=none "${_rockname}-${pkgver}-${_rockrel}.src.rock"
+ luarocks --lua-version=5.1 --tree="$pkgdir/usr" install --deps-mode=none "${_rockname}-${pkgver}-${_rockrel}.src.rock"
find "$pkgdir/usr" -name manifest -delete
}