summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-01-17 15:21:01 -0500
committerSolomon Choina2018-01-17 15:21:01 -0500
commit1dc34930266d3252727c3b98fb49d8f7eeb901d3 (patch)
tree565e6e61e962778ac8ae1c2cd1f8ab6f69304d0f
parent7a3f2a51538d12ff1476485f2a35d7cd62029ca9 (diff)
downloadaur-1dc34930266d3252727c3b98fb49d8f7eeb901d3.tar.gz
update pkgver and adding a the fixed bin
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rwxr-xr-xluacheck3
3 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 167a342d0fa7..30890b40495a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
-# Generated by mksrcinfo v8
-# Thu Jun 15 13:03:42 UTC 2017
pkgbase = lua51-luacheck
pkgdesc = A simple static analyzer
- pkgver = 0.20.0
- pkgrel = 2
+ pkgver = 0.21.2
+ pkgrel = 1
url = https://github.com/mpeterv/luacheck
arch = i686
arch = x86_64
license = MIT
makedepends = luarocks5.1
- depends = lua
+ depends = lua51
depends = lua-filesystem
- source = https://luarocks.org/luacheck-0.20.0-1.src.rock
- sha256sums = a23664b495f14ddb81d6e2bb35fea02885130751de4fc6f8e341fcc79b82be11
+ depends = lua51-filesystem
+ source = https://github.com/mpeterv/luacheck/archive/0.21.2.tar.gz
+ source = luacheck
+ sha256sums = b1528bd73dc0da2c36dc3f93110a83362553546c2f5a354be0c0162149eb1abc
+ sha256sums = b75ff5098951e643061279780c4608049656149c76651d9dd78762e2cecd7584
pkgname = lua51-luacheck
diff --git a/PKGBUILD b/PKGBUILD
index 783ac35b8012..02562c8de827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
#Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=lua51-luacheck
-pkgver=0.20.0
-_rockname=luacheck
-_rockrel=1
-pkgrel=2
+pkgver=0.21.2
+pkgrel=1
pkgdesc="A simple static analyzer"
arch=('i686' 'x86_64')
url="https://github.com/mpeterv/luacheck"
license=('MIT')
-depends=('lua' 'lua-filesystem')
makedepends=('luarocks5.1')
+depends=('lua51' 'lua-filesystem' 'lua51-filesystem')
conflicts=()
-source=("https://luarocks.org/${_rockname}-${pkgver}-${_rockrel}.src.rock")
-sha256sums=('a23664b495f14ddb81d6e2bb35fea02885130751de4fc6f8e341fcc79b82be11')
+source=("https://github.com/mpeterv/luacheck/archive/${pkgver}.tar.gz"
+ "luacheck")
+sha256sums=('b1528bd73dc0da2c36dc3f93110a83362553546c2f5a354be0c0162149eb1abc'
+ 'b75ff5098951e643061279780c4608049656149c76651d9dd78762e2cecd7584')
package() {
- luarocks-5.1 --tree="$pkgdir/usr" install --deps-mode=none "${_rockname}-${pkgver}-${_rockrel}.src.rock"
- find "$pkgdir/usr" -name manifest -delete
-
+ cd ${srcdir}/luacheck-$pkgver
+ luarocks-5.1 --tree="$pkgdir/usr" install --deps-mode=none "luacheck-scm-1.rockspec"
+ find "$pkgdir/usr" -name manifest -delete
+ install ../luacheck $pkgdir/usr/bin
}
diff --git a/luacheck b/luacheck
new file mode 100755
index 000000000000..ecc338ee2589
--- /dev/null
+++ b/luacheck
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec '/usr/bin/lua5.1' -e 'package.path="/usr/share/lua/5.1/?/init.lua;"..package.path; package.cpath="/usr/lib/lua/5.1/?.so;"..package.cpath' -e 'local k,l,_=pcall(require,"luarocks.loader") _=k and l.add_context("luacheck","scm-1")' '/usr/lib/luarocks/rocks-5.1/luacheck/scm-1/bin/luacheck' "$@"