summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-05-09 10:19:05 -0400
committerSolomon Choina2019-05-09 10:19:05 -0400
commit256071568ec507757cab9a79d47f4e065749f91e (patch)
tree1bc3d8a525b00f19ae031290db5148835c1c3738
parent843b0333981e62d1ef3766b9471da9391e831267 (diff)
downloadaur-256071568ec507757cab9a79d47f4e065749f91e.tar.gz
pkgver update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rwxr-xr-xluacheck2
3 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 428c451c6cae..8a2cb0cb633b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = lua51-luacheck
pkgdesc = A simple static analyzer
- pkgver = 0.21.2
- pkgrel = 2
+ pkgver = 0.23.0
+ pkgrel = 1
url = https://github.com/mpeterv/luacheck
arch = i686
arch = x86_64
license = MIT
- makedepends = luarocks5.1
+ makedepends = luarocks
depends = lua51
depends = lua-filesystem
depends = lua51-filesystem
- source = https://github.com/mpeterv/luacheck/archive/0.21.2.tar.gz
+ depends = lua5.1-argparse
+ source = https://github.com/mpeterv/luacheck/archive/0.23.0.tar.gz
source = luacheck
- sha256sums = b1528bd73dc0da2c36dc3f93110a83362553546c2f5a354be0c0162149eb1abc
- sha256sums = b75ff5098951e643061279780c4608049656149c76651d9dd78762e2cecd7584
+ sha256sums = b4edf3a7702519502696d4ac7372ed1bd6a82ded63bf81f2b1d7e9b37711be2b
+ sha256sums = a0f34e7fbe04ef598f03a8645eb8ac5f82c37e8c9fa6421ffffccde0f8e068b3
pkgname = lua51-luacheck
diff --git a/PKGBUILD b/PKGBUILD
index b98f919626fa..95cec226b2eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
#Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=lua51-luacheck
-pkgver=0.21.2
-pkgrel=2
+pkgver=0.23.0
+pkgrel=1
pkgdesc="A simple static analyzer"
arch=('i686' 'x86_64')
url="https://github.com/mpeterv/luacheck"
license=('MIT')
-makedepends=('luarocks5.1')
-depends=('lua51' 'lua-filesystem' 'lua51-filesystem')
+makedepends=('luarocks')
+depends=('lua51' 'lua-filesystem' 'lua51-filesystem' 'lua5.1-argparse')
conflicts=()
source=("https://github.com/mpeterv/luacheck/archive/${pkgver}.tar.gz"
"luacheck")
-sha256sums=('b1528bd73dc0da2c36dc3f93110a83362553546c2f5a354be0c0162149eb1abc'
- 'b75ff5098951e643061279780c4608049656149c76651d9dd78762e2cecd7584')
+sha256sums=('b4edf3a7702519502696d4ac7372ed1bd6a82ded63bf81f2b1d7e9b37711be2b'
+ 'a0f34e7fbe04ef598f03a8645eb8ac5f82c37e8c9fa6421ffffccde0f8e068b3')
+
package() {
cd ${srcdir}/luacheck-$pkgver
- luarocks-5.1 --tree="$pkgdir/usr" make --deps-mode=none "luacheck-scm-1.rockspec"
- find "$pkgdir/usr" -name manifest -delete
- install ../luacheck $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/lua/5.1/luacheck
+ cp -r src/luacheck/ $pkgdir/usr/share/lua/5.1/
+ install -D bin/luacheck.lua $pkgdir/usr/share/lua/5.1/luacheck/bin/luacheck
+ install -D ../luacheck $pkgdir/usr/bin/luacheck
}
diff --git a/luacheck b/luacheck
index ecc338ee2589..43cf02f8aa06 100755
--- a/luacheck
+++ b/luacheck
@@ -1,3 +1,3 @@
#!/bin/sh
-exec '/usr/bin/lua5.1' -e 'package.path="/usr/share/lua/5.1/?/init.lua;"..package.path; package.cpath="/usr/lib/lua/5.1/?.so;"..package.cpath' -e 'local k,l,_=pcall(require,"luarocks.loader") _=k and l.add_context("luacheck","scm-1")' '/usr/lib/luarocks/rocks-5.1/luacheck/scm-1/bin/luacheck' "$@"
+exec '/usr/bin/lua5.1' -e 'package.path="/usr/share/lua/5.1/?/init.lua;"..package.path; package.cpath="/usr/lib/lua/5.1/?.so;"..package.cpath' -e 'local k,l,_=pcall(require,"luarocks.loader") _=k and l.add_context("luacheck","scm-1")' '/usr/share/lua/5.1/luacheck/bin/luacheck' "$@"