summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPitBall2015-11-10 21:41:45 +0100
committerPitBall2015-11-10 21:41:45 +0100
commit29461d3f8220bca32cf7a5b0913ca2133c6230c8 (patch)
tree78ca7b3c2d0539652a86629b3911c32f4220f919
downloadaur-29461d3f8220bca32cf7a5b0913ca2133c6230c8.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD42
-rw-r--r--luabind-0.9.1-boost149fix.patch56
-rw-r--r--luabind-0.9.1-boost157fix.patch22
4 files changed, 151 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e1d35d95ea0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Tue Nov 10 20:41:29 UTC 2015
+pkgbase = lua51bind
+ pkgdesc = A library that helps you create bindings between C++ and Lua51
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = http://www.rasterbar.com/products/luabind.html
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = unzip
+ makedepends = boost
+ makedepends = boost-build
+ depends = lua51
+ depends = gcc-libs
+ provides = luabind
+ conflicts = luabind
+ conflicts = lua52bind
+ conflicts = lua53bind
+ replaces = luabind
+ replaces = lua52bind
+ replaces = lua53bind
+ source = http://downloads.sourceforge.net/luabind/luabind-0.9.1.tar.gz
+ source = luabind-0.9.1-boost149fix.patch
+ source = luabind-0.9.1-boost157fix.patch
+ md5sums = 8a323fb51d07dad5cfdb12c432793d55
+ md5sums = b7315e791201c8f737702a7ccc8e3d69
+ md5sums = a64c06783893c92cd58ef99ce4e94a08
+
+pkgname = lua51bind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..040095c68421
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: PitBall
+
+luaver=5.1
+pkgname=lua${luaver//.}bind
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="A library that helps you create bindings between C++ and Lua51"
+arch=('i686' 'x86_64')
+url="http://www.rasterbar.com/products/luabind.html"
+license=('MIT')
+makedepends=('unzip' 'boost' 'boost-build')
+depends=("lua${luaver//.}" 'gcc-libs')
+replaces=('luabind' 'lua52bind' 'lua53bind')
+conflicts=('luabind' 'lua52bind' 'lua53bind')
+provides=('luabind')
+source=("http://downloads.sourceforge.net/${pkgname//${luaver//.}}/${pkgname//${luaver//.}}-${pkgver}.tar.gz"
+ luabind-0.9.1-boost149fix.patch
+ luabind-0.9.1-boost157fix.patch)
+
+build() {
+ cd ${srcdir}/${pkgname//${luaver//.}}-${pkgver}
+ for diff in ${srcdir}/*.patch; do
+ patch -Np1 -i ${diff}; done
+
+ sed -r -e "s|^(\s*local\ names\s*=\s*).*|\1"liblua${luaver}\ liblua${luaver//.}\ \;"|" -i Jamroot
+
+ b2 -d+2 release --prefix=${pkgdir}/usr/ link=static,shared
+}
+
+package() {
+ cd ${srcdir}/${pkgname//${luaver//.}}-${pkgver}
+
+ b2 release --prefix=${pkgdir}/usr/ link=static,shared install
+
+ # copy license
+ install -Dm644 ${srcdir}/${pkgname//${luaver//.}}-${pkgver}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname//${luaver//.}}/LICENSE
+}
+
+md5sums=('8a323fb51d07dad5cfdb12c432793d55'
+ 'b7315e791201c8f737702a7ccc8e3d69'
+ 'a64c06783893c92cd58ef99ce4e94a08')
diff --git a/luabind-0.9.1-boost149fix.patch b/luabind-0.9.1-boost149fix.patch
new file mode 100644
index 000000000000..a4f38a5843af
--- /dev/null
+++ b/luabind-0.9.1-boost149fix.patch
@@ -0,0 +1,56 @@
+diff -up luabind-0.9.1/luabind/detail/call_function.hpp.boost luabind-0.9.1/luabind/detail/call_function.hpp
+--- luabind-0.9.1/luabind/detail/call_function.hpp.boost 2013-01-14 12:56:44.024217074 -0500
++++ luabind-0.9.1/luabind/detail/call_function.hpp 2013-01-14 12:57:18.598223390 -0500
+@@ -323,7 +323,8 @@ namespace luabind
+
+ #endif // LUABIND_CALL_FUNCTION_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -440,4 +441,4 @@ namespace luabind
+
+
+ #endif
+-
++#endif
+diff -up luabind-0.9.1/luabind/detail/call_member.hpp.boost luabind-0.9.1/luabind/detail/call_member.hpp
+--- luabind-0.9.1/luabind/detail/call_member.hpp.boost 2013-01-14 12:59:09.825244981 -0500
++++ luabind-0.9.1/luabind/detail/call_member.hpp 2013-01-14 12:59:34.069252456 -0500
+@@ -316,7 +316,8 @@ namespace luabind
+
+ #endif // LUABIND_CALL_MEMBER_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -360,4 +361,4 @@ namespace luabind
+ #undef LUABIND_TUPLE_PARAMS
+
+ #endif
+-
++#endif
+diff -up luabind-0.9.1/luabind/wrapper_base.hpp.boost luabind-0.9.1/luabind/wrapper_base.hpp
+--- luabind-0.9.1/luabind/wrapper_base.hpp.boost 2013-01-14 12:59:47.984261884 -0500
++++ luabind-0.9.1/luabind/wrapper_base.hpp 2013-01-14 13:00:05.707268014 -0500
+@@ -89,7 +89,8 @@ namespace luabind
+
+ #endif // LUABIND_WRAPPER_BASE_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -188,3 +189,4 @@ namespace luabind
+ #undef N
+
+ #endif
++#endif
diff --git a/luabind-0.9.1-boost157fix.patch b/luabind-0.9.1-boost157fix.patch
new file mode 100644
index 000000000000..31f2e0d2f952
--- /dev/null
+++ b/luabind-0.9.1-boost157fix.patch
@@ -0,0 +1,22 @@
+diff -up luabind-0.9.1/luabind/object.hpp\~ luabind-0.9.1/luabind/object.hpp
+--- luabind-0.9.1/luabind/object.hpp~ 2015-02-04 02:48:49.558745199 +0100
++++ luabind-0.9.1/luabind/object.hpp 2015-02-04 02:50:22.184188471 +0100
+@@ -551,14 +551,14 @@ namespace detail
+ basic_iterator<basic_access> const& x \
+ , basic_iterator<basic_access> const& y) \
+ { \
+- return boost::operator op(x, y); \
++ return boost::iterators::operator op(x, y); \
+ } \
+ \
+ inline bool operator op( \
+ basic_iterator<raw_access> const& x \
+ , basic_iterator<raw_access> const& y) \
+ { \
+- return boost::operator op(x, y); \
++ return boost::iterators::operator op(x, y); \
+ }
+
+ LUABIND_OPERATOR_ADL_WKND(==)
+
+Diff finished. Wed Feb 4 02:52:16 2015