summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcelogeek2023-09-23 10:44:19 +0200
committercelogeek2023-09-23 10:45:08 +0200
commit69b8e9ce49a7837ab814ccce02225284e52cdc3e (patch)
tree6590b063375097b0f0361210404a6c32a099ce57
parent046569415c5b660a003c33bab415bff7bdabb1ad (diff)
downloadaur-69b8e9ce49a7837ab814ccce02225284e52cdc3e.tar.gz
remove git deps
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD10
3 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 246143d65dd2..6b219e175fbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = lua52-base64
pkgdesc = LUA JWT Jitsi
pkgver = 1.5.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/iskolbin/lbase64
arch = any
license = MIT
makedepends = luarocks
makedepends = lua52
- source = git+https://github.com/iskolbin/lbase64#tag=v1.5.3
- sha256sums = SKIP
+ source = https://github.com/iskolbin/lbase64/archive/refs/tags/v1.5.3.tar.gz
+ sha256sums = 2c4db293cc6f76ef14bf051afd74fe347e7b39f85e825431e5f786e70ff76bae
pkgname = lua52-base64
-
diff --git a/.gitignore b/.gitignore
index 43ae87760f5f..d203986ce4b3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
*.pkg.tar.zst
-lbase64/
+v*.tar.gz
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 6c0b2d425e49..31f9b253e6e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
pkgname=lua52-base64
pkgver=1.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='LUA JWT Jitsi'
arch=('any')
url='https://github.com/iskolbin/lbase64'
license=('MIT')
makedepends=('luarocks' 'lua52')
-source=("git+https://github.com/iskolbin/lbase64#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("https://github.com/iskolbin/lbase64/archive/refs/tags/v${pkgver}.tar.gz")
build() {
- cd "lbase64"
+ cd "lbase64-${pkgver}"
luarocks make --pack-binary-rock --lua-version="5.2" --deps-mode=none rockspec/base64-1.5-3.rockspec
}
package() {
- cd "lbase64"
+ cd "lbase64-${pkgver}"
luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none --no-manifest *.rock
}
+sha256sums=('2c4db293cc6f76ef14bf051afd74fe347e7b39f85e825431e5f786e70ff76bae')