summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcelogeek2023-09-23 10:48:32 +0200
committercelogeek2023-09-23 10:48:32 +0200
commitce4696150cb00f6ebb4d7bfa4e36e39531d3eec8 (patch)
tree4aa2a88c242a3245e9f6148aff813175c73b5257
parent4a8bb549b7729a9e359b5f8a97b1ebbe6e8e55ab (diff)
downloadaur-lua52-jwtjitsi.tar.gz
remove git deps
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97eec5be7293..dfee18a3b8ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lua52-jwtjitsi
pkgdesc = LUA JWT Jitsi
pkgver = 2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jitsi/luajwtjitsi
arch = any
license = MIT
@@ -10,8 +10,7 @@ pkgbase = lua52-jwtjitsi
depends = lua52-cjson
depends = lua52-base64
depends = lua52-luaossl
- source = git+https://github.com/jitsi/luajwtjitsi#tag=v2.0
- sha256sums = SKIP
+ source = https://github.com/jitsi/luajwtjitsi/archive/refs/tags/v2.0.tar.gz
+ sha256sums = c07f427449e4c2e828547e0d32f92377464206e84ffa5ba5d04d0bb2eb7fbb5d
pkgname = lua52-jwtjitsi
-
diff --git a/.gitignore b/.gitignore
index abf374ba10e7..e8952dcab4ba 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
lua52-jwtjitsi*.pkg.tar.zst
luajwtjitsi/
+v*.tar.gz
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 7e56aa4fdd0a..cd0ff5a3b534 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,25 @@
pkgname=lua52-jwtjitsi
pkgver=2.0
-pkgrel=2
+pkgrel=3
pkgdesc='LUA JWT Jitsi'
arch=('any')
url='https://github.com/jitsi/luajwtjitsi'
license=('MIT')
depends=('lua52-cjson' 'lua52-base64' 'lua52-luaossl')
makedepends=('luarocks' 'lua52')
-source=("git+https://github.com/jitsi/luajwtjitsi#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("https://github.com/jitsi/luajwtjitsi/archive/refs/tags/v${pkgver}.tar.gz")
build() {
- cd "luajwtjitsi"
+ cd "luajwtjitsi-${pkgver}"
luarocks make --pack-binary-rock --lua-version="5.2" --deps-mode=none luajwtjitsi*.rockspec
}
package() {
- cd "luajwtjitsi"
+ cd "luajwtjitsi-${pkgver}"
luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none --no-manifest *.rock
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+sha256sums=('c07f427449e4c2e828547e0d32f92377464206e84ffa5ba5d04d0bb2eb7fbb5d')