summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcelogeek2021-05-10 18:47:14 +0200
committercelogeek2021-05-10 18:49:00 +0200
commit5d0d8cf1b0e0642cab83208129e25ca43c641879 (patch)
tree60bd97d3adac6768aa1cff95822bbaf91018e50b
downloadaur-5d0d8cf1b0e0642cab83208129e25ca43c641879.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bfc0e7cf602
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lua52-jwtjitsi-git
+ pkgdesc = LUA JWT Jitsi
+ pkgver = 2.0.r1.gd0398d9
+ pkgrel = 1
+ url = https://github.com/jitsi/luajwtjitsi
+ arch = any
+ license = MIT
+ makedepends = luarocks
+ makedepends = lua52
+ source = git+https://github.com/jitsi/luajwtjitsi
+ sha256sums = SKIP
+
+pkgname = lua52-jwtjitsi-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4608e8c9343a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+lua52-jwtjitsi-git*.pkg.tar.zst
+luajwtjitsi/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd26005998de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daurnimator <daurnimator@archlinux.org>
+
+_pkgname=lua52-jwtjitsi
+pkgname=lua52-jwtjitsi-git
+provide=("$_pkgname")
+pkgver=2.0.r1.gd0398d9
+pkgrel=1
+pkgdesc='LUA JWT Jitsi'
+arch=('any')
+url='https://github.com/jitsi/luajwtjitsi'
+license=('MIT')
+makedepends=('luarocks' 'lua52')
+source=("git+https://github.com/jitsi/luajwtjitsi")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "luajwtjitsi"
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "luajwtjitsi"
+ luarocks make --pack-binary-rock --lua-version="5.2" --deps-mode=none luajwtjitsi*.rockspec
+}
+
+package() {
+ cd "luajwtjitsi"
+ luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none --no-manifest *.rock
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+
+