summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortdy2017-02-06 06:46:42 -0600
committertdy2017-02-06 06:46:42 -0600
commit76364f1a0c972aad072da851fee55784dd9cf879 (patch)
treeb85b265211d78ad860ddba4b8c17cf5f62bb543f
downloadaur-76364f1a0c972aad072da851fee55784dd9cf879.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..141ad7694740
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lua52-posix
+ pkgdesc = Lua 5.2 bindings for POSIX APIs
+ pkgver = 33.4.0
+ pkgrel = 1
+ url = https://github.com/luaposix/luaposix
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = lua52
+ source = https://github.com/luaposix/luaposix/archive/release-v33.4.0.tar.gz
+ sha256sums = e66262f5b7fe1c32c65f17a5ef5ffb31c4d1877019b4870a5d373e2ab6526a21
+
+pkgname = lua52-posix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..106ebbcf9d2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: archlinux.info:tdy
+
+pkgname=lua52-posix
+pkgver=33.4.0
+pkgrel=1
+pkgdesc="Lua 5.2 bindings for POSIX APIs"
+arch=(i686 x86_64)
+url=https://github.com/luaposix/luaposix
+license=(MIT)
+depends=(lua52)
+source=(https://github.com/luaposix/luaposix/archive/release-v$pkgver.tar.gz)
+sha256sums=(e66262f5b7fe1c32c65f17a5ef5ffb31c4d1877019b4870a5d373e2ab6526a21)
+
+prepare() {
+ cd luaposix-release-v$pkgver
+ export LUA=/usr/bin/lua5.2
+ export LUA_INCLUDE=-I/usr/include/lua5.2
+}
+
+build() {
+ cd luaposix-release-v$pkgver
+ ./configure --prefix=/usr --libdir=/usr/lib/lua/5.2 --datadir=/usr/share/lua/5.2
+ make
+}
+
+check() {
+ cd luaposix-release-v$pkgver
+ make -k check
+}
+
+package() {
+ cd luaposix-release-v$pkgver
+ make DESTDIR="$pkgdir" install
+ install COPYING -m 644 -Dt "$pkgdir"/usr/share/licenses/$pkgname/
+}