summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-06-13 15:34:08 +0200
committerMarco Pompili2015-06-13 15:34:08 +0200
commit06e61b9737a723f595cc5685bf52a12635bed2ee (patch)
treee2e2b9763bbd27010ba8d7cc0513904c0b4028ce
downloadaur-06e61b9737a723f595cc5685bf52a12635bed2ee.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD43
-rw-r--r--boost_1.57.patch22
-rw-r--r--luabind_boost.patch59
4 files changed, 146 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5aba6e043f30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = luabind
+ pkgdesc = A library that helps you create bindings between C++ and Lua
+ pkgver = 0.9.1
+ pkgrel = 5
+ url = http://www.rasterbar.com/products/luabind.html
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = unzip
+ makedepends = boost
+ makedepends = boost-build
+ depends = lua51
+ depends = gcc-libs
+ source = http://downloads.sourceforge.net/luabind/luabind-0.9.1.tar.gz
+ source = luabind_boost.patch
+ source = boost_1.57.patch
+ md5sums = 8a323fb51d07dad5cfdb12c432793d55
+ md5sums = d62ae6fc635300bc659df9dbb587ac53
+ md5sums = 92450a08bc1eed7957109a6c712b1d45
+
+pkgname = luabind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c69fcc47fa6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id: PKGBUILD 78820 2012-10-25 06:47:28Z foutrelis $
+# Maintainer: Marco Pompili <marcs.pompili@gmail.com>
+# Maintainer: Jakob Gruber <jakob.gruber@gmail.com>
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: rayte <rabyte.at.gmail.dot.com>
+
+pkgname=luabind
+pkgver=0.9.1
+pkgrel=5
+pkgdesc="A library that helps you create bindings between C++ and Lua"
+arch=('i686' 'x86_64')
+url="http://www.rasterbar.com/products/luabind.html"
+license=('MIT')
+makedepends=('unzip' 'boost' 'boost-build')
+depends=('lua51' 'gcc-libs')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "luabind_boost.patch"
+ "boost_1.57.patch")
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ patch -Np1 -i ${srcdir}/luabind_boost.patch
+ patch -Np1 -i ${srcdir}/boost_1.57.patch
+
+ # build luabind
+ export LUA_PATH=/usr/include/lua51
+ b2 release --prefix=${pkgdir}/usr/ link=static,shared
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ b2 release --prefix=${pkgdir}/usr/ link=static,shared install
+
+ # copy license
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+md5sums=('8a323fb51d07dad5cfdb12c432793d55'
+ 'd62ae6fc635300bc659df9dbb587ac53'
+ '92450a08bc1eed7957109a6c712b1d45')
diff --git a/boost_1.57.patch b/boost_1.57.patch
new file mode 100644
index 000000000000..d7fc6e41d815
--- /dev/null
+++ b/boost_1.57.patch
@@ -0,0 +1,22 @@
+--- luabind-0.91/luabind/object.hpp 2010-08-31 15:24:52.000000000 +0200
++++ luabind-0.91/luabind/object.hpp.fix 2015-05-30 09:40:59.212520185 +0200
+@@ -536,6 +536,8 @@
+ handle m_key;
+ };
+
++#if BOOST_VERSION < 105700
++
+ // Needed because of some strange ADL issues.
+
+ #define LUABIND_OPERATOR_ADL_WKND(op) \
+@@ -557,7 +559,9 @@
+ LUABIND_OPERATOR_ADL_WKND(!=)
+
+ #undef LUABIND_OPERATOR_ADL_WKND
+-
++
++#endif
++
+ } // namespace detail
+
+ namespace adl
diff --git a/luabind_boost.patch b/luabind_boost.patch
new file mode 100644
index 000000000000..92e32828a03c
--- /dev/null
+++ b/luabind_boost.patch
@@ -0,0 +1,59 @@
+diff --git luabind-0.9.1/luabind/detail/call_function.hpp luabind-0.9.1-fixed/luabind/detail/call_function.hpp
+index 1b45ec1..8f5afff 100644
+--- luabind-0.9.1/luabind/detail/call_function.hpp
++++ luabind-0.9.1-fixed/luabind/detail/call_function.hpp
+@@ -323,7 +323,8 @@ namespace luabind
+
+ #endif // LUABIND_CALL_FUNCTION_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -440,4 +441,5 @@ namespace luabind
+
+
+ #endif
++#endif
+
+diff --git luabind-0.9.1/luabind/detail/call_member.hpp luabind-0.9.1-fixed/luabind/detail/call_member.hpp
+index de8d563..e63555b 100644
+--- luabind-0.9.1/luabind/detail/call_member.hpp
++++ luabind-0.9.1-fixed/luabind/detail/call_member.hpp
+@@ -316,7 +316,8 @@ namespace luabind
+
+ #endif // LUABIND_CALL_MEMBER_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -360,4 +361,5 @@ namespace luabind
+ #undef LUABIND_TUPLE_PARAMS
+
+ #endif
++#endif
+
+diff --git luabind-0.9.1/luabind/wrapper_base.hpp luabind-0.9.1-fixed/luabind/wrapper_base.hpp
+index d54c668..0f88cc5 100755
+--- luabind-0.9.1/luabind/wrapper_base.hpp
++++ luabind-0.9.1-fixed/luabind/wrapper_base.hpp
+@@ -89,7 +89,8 @@ namespace luabind
+
+ #endif // LUABIND_WRAPPER_BASE_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -188,3 +189,4 @@ namespace luabind
+ #undef N
+
+ #endif
++#endif