summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2016-03-06 15:01:11 +0100
committerMarco Pompili2016-03-06 15:01:11 +0100
commit6e3b056999e5ace33330d5fb4ccb71c772c9884d (patch)
tree50b3ebc3f0e1d73cd7253cacb246adb74cfe2749
parent9c813ce3594c57378575e03fc68fb31f1f4c3212 (diff)
downloadaur-6e3b056999e5ace33330d5fb4ccb71c772c9884d.tar.gz
Version 0.9.1-6, update to lua 5.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5aba6e043f30..4e9a3a73a5fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Mar 6 14:00:19 UTC 2016
pkgbase = luabind
pkgdesc = A library that helps you create bindings between C++ and Lua
pkgver = 0.9.1
- pkgrel = 5
+ pkgrel = 6
url = http://www.rasterbar.com/products/luabind.html
arch = i686
arch = x86_64
license = MIT
makedepends = unzip
makedepends = boost
- makedepends = boost-build
- depends = lua51
+ depends = lua
depends = gcc-libs
source = http://downloads.sourceforge.net/luabind/luabind-0.9.1.tar.gz
source = luabind_boost.patch
diff --git a/PKGBUILD b/PKGBUILD
index c69fcc47fa6b..541f7e09e095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,20 @@
pkgname=luabind
pkgver=0.9.1
-pkgrel=5
+pkgrel=6
pkgdesc="A library that helps you create bindings between C++ and Lua"
arch=('i686' 'x86_64')
url="http://www.rasterbar.com/products/luabind.html"
license=('MIT')
-makedepends=('unzip' 'boost' 'boost-build')
-depends=('lua51' 'gcc-libs')
+makedepends=('unzip' 'boost')
+depends=('lua' 'gcc-libs')
source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
"luabind_boost.patch"
- "boost_1.57.patch")
+ "boost_1.57.patch")
+
+md5sums=('8a323fb51d07dad5cfdb12c432793d55'
+ 'd62ae6fc635300bc659df9dbb587ac53'
+ '92450a08bc1eed7957109a6c712b1d45')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
@@ -24,7 +28,8 @@ build() {
patch -Np1 -i ${srcdir}/boost_1.57.patch
# build luabind
- export LUA_PATH=/usr/include/lua51
+ # export LUA_PATH=/usr/include/lua51
+ # export LUA_PATH=/usr/include/lua52
b2 release --prefix=${pkgdir}/usr/ link=static,shared
}
@@ -37,7 +42,3 @@ package() {
install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE \
${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
-
-md5sums=('8a323fb51d07dad5cfdb12c432793d55'
- 'd62ae6fc635300bc659df9dbb587ac53'
- '92450a08bc1eed7957109a6c712b1d45')