summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas2022-02-01 15:44:17 +0100
committerThomas2022-02-01 15:44:17 +0100
commit6975db7132e432500f7a9606fb79a2ec3fa806d5 (patch)
treed13dfac3fb6fdea979e951863f004b76869e60b1
downloadaur-6975db7132e432500f7a9606fb79a2ec3fa806d5.tar.gz
Create luabind packages forked by ryzom
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..909aeafd906d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = luabind-ryzom-git
+ pkgdesc = A library that helps you create bindings between C++ and Lua
+ pkgver = v0.9.r145.ga0edf58
+ pkgrel = 1
+ url = http://www.rasterbar.com/products/luabind.html
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = boost-build
+ depends = lua
+ depends = gcc-libs
+ provides = luabind
+ source = luabind::git+https://github.com/ryzom/luabind.git
+ md5sums = SKIP
+
+pkgname = luabind-ryzom-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..842439f5d078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=luabind-ryzom-git
+pkgver=v0.9.r145.ga0edf58
+pkgrel=1
+provides=('luabind')
+pkgdesc="A library that helps you create bindings between C++ and Lua"
+arch=('i686' 'x86_64')
+url="http://www.rasterbar.com/products/luabind.html"
+license=('MIT')
+makedepends=('boost' 'boost-build')
+depends=('lua' 'gcc-libs')
+source=("luabind::git+https://github.com/ryzom/luabind.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd luabind
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+build() {
+ cd ${srcdir}/luabind
+ bjam
+}
+
+package() {
+ cd ${srcdir}/luabind
+ bjam --prefix=${pkgdir}/usr/ install
+ cd ${pkgdir}/usr/lib
+ ln -s libluabindd.so libluabind.so
+}