summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-03-24 13:47:36 +0300
committerCaleb Maclennan2022-03-24 13:47:36 +0300
commit01d2769a136c2518f6d45ab520be962fedb4db33 (patch)
tree9c9a52a2ee9184b2a3bd390c463fd4215df3b5d0
parentf7bd62fdfba91e8ee06b0c5b1a5e7bc04bff3977 (diff)
downloadaur-luacheck.tar.gz
upgpkg: luacheck 0.26.0-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f5c6f32a421..66e6f4d587ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luacheck
pkgdesc = A tool for linting and static analysis of Lua code
- pkgver = 0.25.0
- pkgrel = 3
+ pkgver = 0.26.0
+ pkgrel = 1
url = https://github.com/lunarmodules/luacheck
arch = any
license = MIT
@@ -10,7 +10,7 @@ pkgbase = luacheck
depends = lua-filesystem
depends = lua-argparse
optdepends = lua-lanes: for parallel checking
- source = https://github.com/lunarmodules/luacheck/archive/0.25.0/luacheck-0.25.0.tar.gz
- sha256sums = 4507648bee9e67b2d30058f7befbbb58cd387a2503f4f348c2aae6e93417aaa1
+ source = https://github.com/lunarmodules/luacheck/archive/v0.26.0/luacheck-0.26.0.tar.gz
+ sha256sums = 78b74cae0e94155e500755c8e60d921ee7250cfec2acd8ab4df480625c425594
pkgname = luacheck
diff --git a/PKGBUILD b/PKGBUILD
index 2877c8df2e29..149c6d93ca5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
pkgname=luacheck
-pkgver=0.25.0
-pkgrel=3
+pkgver=0.26.0
+pkgrel=1
+_rockrel=1
pkgdesc='A tool for linting and static analysis of Lua code'
arch=(any)
url="https://github.com/lunarmodules/$pkgname"
@@ -15,17 +16,17 @@ depends=(lua
makedepends=(luarocks)
optdepends=('lua-lanes: for parallel checking')
_archive="$pkgname-$pkgver"
-source=("$url/archive/$pkgver/$_archive.tar.gz")
-sha256sums=('4507648bee9e67b2d30058f7befbbb58cd387a2503f4f348c2aae6e93417aaa1')
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
+sha256sums=('78b74cae0e94155e500755c8e60d921ee7250cfec2acd8ab4df480625c425594')
build() {
cd "$_archive"
- luarocks make --pack-binary-rock --deps-mode=none --no-manifest -- $pkgname-*.rockspec
+ luarocks make --pack-binary-rock --deps-mode=none --no-manifest -- rockspecs/$pkgname-$pkgver-$_rockrel.rockspec
}
package() {
cd "$_archive"
- luarocks install --tree="$pkgdir/usr" --deps-mode=none --no-manifest -- $pkgname-*.all.rock
+ luarocks install --tree="$pkgdir/usr" --deps-mode=none --no-manifest -- $pkgname-$pkgver-$_rockrel.all.rock
sed -i -e "s!$pkgdir!!" "$pkgdir/usr/bin/$pkgname"
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}