summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-03-23 16:59:53 +0300
committerCaleb Maclennan2022-03-23 16:59:53 +0300
commit74a9af2e30501cacec6266c5c27a2baea41218b6 (patch)
tree2120ddc7100b2bafaa43193d39c8401fc44baba7
parent0270fbd3810ba80f76313788aaa44cda480ec551 (diff)
downloadaur-74a9af2e30501cacec6266c5c27a2baea41218b6.tar.gz
upgpkg: luacheck 0.25.0-2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0bbcb664b90..b9bd2c84d99f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = luacheck
- pkgdesc = A tool for linting and static analysis of Lua code.
+ pkgdesc = A tool for linting and static analysis of Lua code
pkgver = 0.25.0
- pkgrel = 1
- url = https://github.com/luarocks/luacheck
+ pkgrel = 2
+ url = https://github.com/lunarmodules/luacheck
arch = any
license = MIT
+ makedepends = luarocks
depends = lua
depends = lua-filesystem
depends = lua-argparse
optdepends = lua-lanes: for parallel checking
- source = luacheck-0.25.0.tar.gz::https://github.com/luarocks/luacheck/archive/0.25.0.tar.gz
+ source = https://github.com/lunarmodules/luacheck/archive/0.25.0/luacheck-0.25.0.tar.gz
sha256sums = 4507648bee9e67b2d30058f7befbbb58cd387a2503f4f348c2aae6e93417aaa1
pkgname = luacheck
diff --git a/PKGBUILD b/PKGBUILD
index b93f666303d4..0a35a0a1d713 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
# Contributor: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
pkgname=luacheck
pkgver=0.25.0
-pkgrel=1
-pkgdesc="A tool for linting and static analysis of Lua code."
-arch=('any')
-url="https://github.com/luarocks/luacheck"
-license=('MIT')
-depends=('lua' 'lua-filesystem' 'lua-argparse')
+pkgrel=2
+pkgdesc='A tool for linting and static analysis of Lua code'
+arch=(any)
+url="https://github.com/lunarmodules/$pkgname"
+license=(MIT)
+depends=(lua
+ lua-filesystem
+ lua-argparse)
+makedepends=(luarocks)
optdepends=('lua-lanes: for parallel checking')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/luarocks/$pkgname/archive/$pkgver.tar.gz")
+_archive="$pkgname-$pkgver"
+source=("$url/archive/$pkgver/$_archive.tar.gz")
sha256sums=('4507648bee9e67b2d30058f7befbbb58cd387a2503f4f348c2aae6e93417aaa1')
package() {
- cd "$pkgname-$pkgver"
- LUA_VERSION=5.4
- for subdir in . builtin_standards stages vendor/sha1; do
- find src/luacheck/$subdir -maxdepth 1 -type f -exec install -Dm644 {} -t "$pkgdir/usr/share/lua/$LUA_VERSION/luacheck/$subdir" \;
- done
- install -Dm755 "bin/luacheck.lua" "$pkgdir/usr/bin/luacheck"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_archive"
+ luarocks --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}