summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2015-11-24 20:37:16 +0100
committerPieter Goetschalckx2015-11-24 20:37:16 +0100
commit78f3e8367d2efb574eb42c4379a52f294f82a9b3 (patch)
tree1095d9af508ebbb8e058f0222e1d06d38be8b81d
downloadaur-78f3e8367d2efb574eb42c4379a52f294f82a9b3.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rwxr-xr-xluacheck2
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6697fa4d690e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = luacheck
+ pkgdesc = A tool for linting and static analysis of Lua code.
+ pkgver = 0.12.0
+ pkgrel = 1
+ url = https://github.com/mpeterv/luacheck
+ arch = any
+ license = MIT
+ depends = lua
+ source = https://github.com/mpeterv/luacheck/archive/0.12.0.tar.gz
+ source = luacheck
+ sha256sums = 3f8306f5210eeac7dd3057cff7924b487229ebc15a595c0767715d3e4c300e47
+ sha256sums = 5bbc0a1be3684c2691cf34aea8bc5538d819e3591ec3ec363bf4a911f53c8f78
+
+pkgname = luacheck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a641684fc338
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+
+pkgname=luacheck
+pkgver=0.12.0
+pkgrel=1
+pkgdesc="A tool for linting and static analysis of Lua code."
+arch=('any')
+url="https://github.com/mpeterv/luacheck"
+license=('MIT')
+depends=('lua')
+source=("https://github.com/mpeterv/$pkgname/archive/$pkgver.tar.gz"
+ "luacheck")
+sha256sums=('3f8306f5210eeac7dd3057cff7924b487229ebc15a595c0767715d3e4c300e47'
+ '5bbc0a1be3684c2691cf34aea8bc5538d819e3591ec3ec363bf4a911f53c8f78')
+
+package() {
+ install -Dm755 luacheck "$pkgdir/usr/bin/luacheck"
+
+ cd "$pkgname-$pkgver"
+ lua install.lua "$pkgdir/usr/share/luacheck"
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/luacheck b/luacheck
new file mode 100755
index 000000000000..ed6bf703ae0e
--- /dev/null
+++ b/luacheck
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/share/luacheck/bin/luacheck "$@"