summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2018-03-29 21:34:25 +0200
committerosch2018-03-29 21:34:25 +0200
commit9a19df961f052e4cd727a34cb793adf3d1de1de2 (patch)
tree3289a199a77b40ce1ac89235aafb75503e1e24b6
downloadaur-9a19df961f052e4cd727a34cb793adf3d1de1de2.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD46
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31354b8a3d19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = luajack
+ pkgdesc = Lua bindings for the JACK Audio Connection Kit
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://github.com/stetre/luajack
+ arch = x86_64
+ license = MIT
+ depends = lua
+ depends = jack
+ source = https://github.com/stetre/luajack/archive/v0.5.tar.gz
+ md5sums = 4266aafb424e1a337ee7ad2cb13ec25a
+
+pkgname = luajack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f1cce4253fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: osch <oliver at luced de>
+pkgname=luajack
+pkgver=0.5
+pkgrel=1
+epoch=
+pkgdesc="Lua bindings for the JACK Audio Connection Kit"
+arch=('x86_64')
+url="https://github.com/stetre/luajack"
+license=('MIT')
+groups=()
+depends=('lua'
+ 'jack')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/stetre/$pkgname/archive/v$pkgver.tar.gz")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX="$pkgdir/usr" install
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname"
+
+ cd "$pkgdir/usr/lib/"
+ ln -sfv lua/5.3/luajack.so libluajack.so
+}
+md5sums=('4266aafb424e1a337ee7ad2cb13ec25a')