summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12024-01-09 02:45:05 +0800
committerChocobo12024-01-09 02:45:05 +0800
commit6de1b1be30d6cc5333a2d9b6a02ca5b141898cf3 (patch)
treeec83b62aa170dc8f7884b2cce0b5db1672ef82f4
parent486c532f123ba35375e6b9d1d4433ef0750d7dbd (diff)
downloadaur-luajit-git.tar.gz
upgpkg: luajit-git 2.1.r140.gc525bcb9-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
2 files changed, 30 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 253773806c68..4004231a826b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = luajit-git
- pkgdesc = Just-in-time compiler and drop-in replacement for Lua 5.1
- pkgver = 2.0.5.25.g61464b0
+ pkgdesc = Just-In-Time (JIT) compiler for the Lua programming language
+ pkgver = 2.1.r140.gc525bcb9
pkgrel = 1
- url = http://luajit.org/
+ url = https://luajit.org/
arch = i686
arch = x86_64
license = MIT
makedepends = git
depends = gcc-libs
- provides = luajit
+ provides = luajit=2.1.r140.gc525bcb9
conflicts = luajit
- source = git+http://luajit.org/git/luajit-2.0.git
+ options = staticlibs
+ source = git+https://luajit.org/git/luajit.git
sha256sums = SKIP
pkgname = luajit-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 324f068aed10..614baac876bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,39 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
pkgname=luajit-git
-pkgver=2.0.5.25.g61464b0
+pkgver=2.1.r140.gc525bcb9
pkgrel=1
-pkgdesc='Just-in-time compiler and drop-in replacement for Lua 5.1'
+pkgdesc="Just-In-Time (JIT) compiler for the Lua programming language"
arch=('i686' 'x86_64')
-url='http://luajit.org/'
+url="https://luajit.org/"
license=('MIT')
-depends=('gcc-libs')
+depends=('gcc-libs')
makedepends=('git')
+provides=("luajit=$pkgver")
conflicts=('luajit')
-provides=('luajit')
-source=(git+http://luajit.org/git/luajit-2.0.git)
+options=('staticlibs')
+source=("git+https://luajit.org/git/luajit.git")
sha256sums=('SKIP')
+
pkgver() {
- cd luajit-2.0
- git describe | sed 's/^v//;s/-/./g'
+ cd "luajit"
+
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+ROLLING$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/.ROLLING//'
}
-build() {
- cd luajit-2.0
- make amalg PREFIX=/usr
+build() {
+ cd "luajit"
+
+ make TARGET_STRIP=" @:" amalg
}
package() {
- cd luajit-2.0
- make install DESTDIR=$pkgdir PREFIX=/usr
- install -Dm644 COPYRIGHT $pkgdir/usr/share/licenses/$pkgname/COPYRIGHT
+ cd "luajit"
+
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ install -Dm644 "COPYRIGHT" -t "$pkgdir/usr/share/licenses/luajit"
}