summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2018-03-06 22:46:48 +0200
committerStelios Tsampas2018-03-06 22:46:48 +0200
commit9bf6bb4ed7d7e796e28bf6a7997e95d2f0c61182 (patch)
treec3a7293919adadc3de1d8fb3a6730eb03c2bbfa2
parent713d1010f7df9c122f941e89e36d092573053203 (diff)
downloadaur-9bf6bb4ed7d7e796e28bf6a7997e95d2f0c61182.tar.gz
Remove conflicts and replaces arrays
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 4 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f996e751168..59c513a8a6bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,8 +11,6 @@ pkgbase = luajit-lgi
depends = libffi
depends = luajit
depends = gobject-introspection-runtime
- conflicts = lgi
- replaces = lgi
source = lgi-0.9.2.tar.gz::https://github.com/pavouk/lgi/archive/0.9.2.tar.gz
sha512sums = 755a96b78530f42da6d4e2664f8e37cb07a356419e7e6448003c3f841c9d98ad18b851715d9eb203ea7eb27b13ec46223fa8a1c90a99fd12960ce85b0a695335
diff --git a/PKGBUILD b/PKGBUILD
index 4e7114711e20..79e8f4b2304d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,6 @@
# Contributor: Sébastien Luttringer <seblu@archlinux.org>
# Contributor: Alain Kalker <a dot c dot kalker at gmail dot com>
-_pkgbase=lgi
pkgname=('luajit-lgi')
pkgver=0.9.2
pkgrel=1
@@ -14,25 +13,23 @@ arch=('x86_64')
license=('MIT')
depends=('glibc' 'glib2' 'libffi' 'luajit' 'gobject-introspection-runtime')
makedepends=('gobject-introspection')
-replaces=('lgi')
-conflicts=('lgi')
-source=(${_pkgbase}-${pkgver}.tar.gz::https://github.com/pavouk/lgi/archive/${pkgver}.tar.gz)
+source=(lgi-${pkgver}.tar.gz::https://github.com/pavouk/lgi/archive/${pkgver}.tar.gz)
sha512sums=('755a96b78530f42da6d4e2664f8e37cb07a356419e7e6448003c3f841c9d98ad18b851715d9eb203ea7eb27b13ec46223fa8a1c90a99fd12960ce85b0a695335')
build() {
- cd ${_pkgbase}-${pkgver}
+ cd lgi-${pkgver}
make LUA_INCDIR=/usr/include/luajit-2.0/ \
LUA_CFLAGS="$(pkg-config --cflags luajit) -O2"
}
check() {
- cd ${_pkgbase}-${pkgver}
+ cd lgi-${pkgver}
# TODO: fix cairo-gobject dependency
# make check
}
package_luajit-lgi() {
- cd ${_pkgbase}-${pkgver}
+ cd lgi-${pkgver}
make \
LUA_LIBDIR=/usr/lib/lua/5.1 \
LUA_SHAREDIR=/usr/share/lua/5.1 \