summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorghesy2022-10-15 04:53:55 +0330
committerghesy2022-10-15 04:53:55 +0330
commitf28e41f482a30882384f04997ada599bc4c38e86 (patch)
tree07579fa3c1685af1705605843ca9ab3135ccc1db
downloadaur-f28e41f482a30882384f04997ada599bc4c38e86.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD37
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14aa6aca84c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = luastatus
+ pkgdesc = universal status bar content generator
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/shdown/luastatus
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = pkg-config
+ makedepends = python-docutils
+ depends = lua<5.5
+ optdepends = libxcb>=1.10: for barlib 'dwm' and plugin 'xtitle'
+ optdepends = yajl>=2.0.4: for barlib 'i3'
+ optdepends = alsa-lib>=1.0.27.2: for plugin 'alsa'
+ optdepends = libudev>=204.0: for plugin 'battery-linux', 'backlight-linux' and 'udev'
+ optdepends = glib2>=2.40.2: for plugin 'dbus'
+ optdepends = linux-headers: for plugin 'network'
+ optdepends = libnl>=3.0: for plugin 'network'
+ optdepends = libpulse>=4.0: for plugin 'pulse'
+ optdepends = xcb-util>=0.3.8: for plugin 'xtitle'
+ optdepends = xcb-util-wm>=0.4.1: for plugin 'xtitle'
+ source = https://github.com/shdown/luastatus/archive/refs/tags/v0.6.0.tar.gz
+ sha256sums = b4ccebc771c315c137cd29ce3ab737ac28a4d32db6a4ac956405b33968fe4ddc
+
+pkgname = luastatus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e855ae4bc9bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Ehsan Ghorbannezhad <ehsan at disroot dot org>
+
+pkgname=luastatus
+pkgver=0.6.0
+pkgrel=1
+pkgdesc='universal status bar content generator'
+url='https://github.com/shdown/luastatus'
+arch=('x86_64')
+license=('LGPL3')
+depends=('lua<5.5')
+makedepends=('cmake' 'pkg-config' 'python-docutils')
+optdepends=(
+ "libxcb>=1.10: for barlib 'dwm' and plugin 'xtitle'"
+ "yajl>=2.0.4: for barlib 'i3'"
+ "alsa-lib>=1.0.27.2: for plugin 'alsa'"
+ "libudev>=204.0: for plugin 'battery-linux', 'backlight-linux' and 'udev'"
+ "glib2>=2.40.2: for plugin 'dbus'"
+ "linux-headers: for plugin 'network'"
+ "libnl>=3.0: for plugin 'network'"
+ "libpulse>=4.0: for plugin 'pulse'"
+ "xcb-util>=0.3.8: for plugin 'xtitle'"
+ "xcb-util-wm>=0.4.1: for plugin 'xtitle'"
+)
+source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('b4ccebc771c315c137cd29ce3ab737ac28a4d32db6a4ac956405b33968fe4ddc')
+
+build() {
+ cd "luastatus-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib \
+ -DWITH_LUA_LIBRARY=lua-5.4 .
+ make
+}
+
+package() {
+ cd "luastatus-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}