summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetRUShka2019-07-30 22:48:18 +0300
committerpetRUShka2019-07-30 22:48:18 +0300
commitfb1b4db23963493c6a4809d90c2c6263d7d94307 (patch)
tree2babee46c628473b67cfa84a53df70573d19c3ef
downloadaur-fb1b4db23963493c6a4809d90c2c6263d7d94307.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD29
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5fa2f5b4633
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = luastatus-git
+ pkgdesc = luastatus is a universal status bar content generator
+ pkgver = r564.29fa981
+ pkgrel = 1
+ url = https://github.com/shdown/luastatus
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = pkg-config
+ depends = lua
+ depends = libx11
+ depends = bash
+ depends = alsa-lib
+ depends = yajl>=2.1.0
+ depends = xcb-util-wm
+ provides = luastatus
+ conflicts = luastatus
+ source = git+https://github.com/shdown/luastatus
+ sha1sums = SKIP
+
+pkgname = luastatus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4a57ef5a364
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=luastatus-git
+pkgver=r564.29fa981
+pkgrel=1
+pkgdesc='luastatus is a universal status bar content generator'
+arch=('x86_64')
+url='https://github.com/shdown/luastatus'
+license=('LGPL3')
+depends=('lua' 'libx11' 'bash' 'alsa-lib' 'yajl>=2.1.0' 'xcb-util-wm')
+makedepends=('git' 'cmake' 'pkg-config')
+conflicts=('luastatus')
+provides=('luastatus')
+source=(git+https://github.com/shdown/luastatus)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ make DESTDIR="$pkgdir" install
+}