summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorghesy2022-10-30 00:23:09 +0330
committerghesy2022-10-30 00:23:09 +0330
commit97de075dc13e7ec8abf56ec1e96c82b8b3517eb0 (patch)
tree7a83d75efc731ad487cbf2e5c5e4ed0f90985b60
downloadaur-97de075dc13e7ec8abf56ec1e96c82b8b3517eb0.tar.gz
initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD62
2 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a20c8225e9e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = luastatus-luajit-git
+ pkgdesc = luastatus (a status bar content generator) built with luajit for better performance - git version
+ pkgver = r772.525942c
+ pkgrel = 1
+ url = https://github.com/shdown/luastatus
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = pkg-config
+ makedepends = python-docutils
+ makedepends = libxcb>=1.10
+ makedepends = yajl>=2.0.4
+ makedepends = alsa-lib>=1.0.27.2
+ makedepends = libpulse>=4.0
+ makedepends = libudev>=204.0
+ makedepends = libnl>=3.0
+ makedepends = glib2>=2.40.2
+ makedepends = libx11>=1.6.2
+ makedepends = xcb-util>=0.3.8
+ makedepends = xcb-util-wm>=0.4.1
+ depends = luajit>=2.0.0
+ optdepends = lua51-luautf8: for general UTF-8 support
+ optdepends = libxcb>=1.10: for barlib 'dwm' and plugin 'xtitle'
+ optdepends = yajl>=2.0.4: for barlib 'i3'
+ optdepends = alsa-lib>=1.0.27.2: for plugin 'alsa'
+ optdepends = libpulse>=4.0: for plugin 'pulse'
+ optdepends = libudev>=204.0: for plugin 'battery-linux', 'backlight-linux' and 'udev'
+ optdepends = libnl>=3.0: for plugin 'network'
+ optdepends = glib2>=2.40.2: for plugin 'dbus'
+ optdepends = libx11>=1.6.2: for plugin 'xkb'
+ optdepends = xcb-util>=0.3.8: for plugin 'xtitle'
+ optdepends = xcb-util-wm>=0.4.1: for plugin 'xtitle'
+ provides = luastatus
+ conflicts = luastatus
+ source = git+https://github.com/shdown/luastatus.git
+ sha256sums = SKIP
+
+pkgname = luastatus-luajit-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef59cb7b169f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: ghesy <ehsan at disroot dot org>
+
+pkgname=luastatus-luajit-git
+pkgver=r772.525942c
+pkgrel=1
+pkgdesc='luastatus (a status bar content generator) built with luajit for better performance - git version'
+url='https://github.com/shdown/luastatus'
+arch=('x86_64')
+license=('LGPL3')
+provides=('luastatus')
+conflicts=('luastatus')
+depends=('luajit>=2.0.0')
+makedepends=(
+ 'git'
+ 'cmake'
+ 'pkg-config'
+ 'python-docutils'
+ 'libxcb>=1.10'
+ 'yajl>=2.0.4'
+ 'alsa-lib>=1.0.27.2'
+ 'libpulse>=4.0'
+ 'libudev>=204.0'
+ 'libnl>=3.0'
+ 'glib2>=2.40.2'
+ 'libx11>=1.6.2'
+ 'xcb-util>=0.3.8'
+ 'xcb-util-wm>=0.4.1'
+)
+optdepends=(
+ "lua51-luautf8: for general UTF-8 support"
+ "libxcb>=1.10: for barlib 'dwm' and plugin 'xtitle'"
+ "yajl>=2.0.4: for barlib 'i3'"
+ "alsa-lib>=1.0.27.2: for plugin 'alsa'"
+ "libpulse>=4.0: for plugin 'pulse'"
+ "libudev>=204.0: for plugin 'battery-linux', 'backlight-linux' and 'udev'"
+ "libnl>=3.0: for plugin 'network'"
+ "glib2>=2.40.2: for plugin 'dbus'"
+ "libx11>=1.6.2: for plugin 'xkb'"
+ "xcb-util>=0.3.8: for plugin 'xtitle'"
+ "xcb-util-wm>=0.4.1: for plugin 'xtitle'"
+)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd 'luastatus'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd 'luastatus'
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib \
+ -DWITH_LUA_LIBRARY=luajit -DBUILD_PLUGIN_PULSE=ON .
+ make
+}
+
+package() {
+ cd 'luastatus'
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:noexpandtab