summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-06-16 22:27:15 +0800
committertaotieren2021-06-16 22:27:15 +0800
commitd47a1f6dff11f383a96c57bfa1a1d907c6cf5cf9 (patch)
treee31223c6c0ea4168b16dd098fba02973523109f1
downloadaur-luatools-wine.tar.gz
Update testing luatools-wine
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD128
-rw-r--r--luatools-wine.install17
4 files changed, 174 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8915cf61c1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = luatools-wine
+ pkgdesc = Wine LuatTools 是合宙的 Lua 调试工具
+ pkgver = 2_1_17
+ pkgrel = 1
+ url = https://doc.openluat.com/wiki/3?wiki_page_id=694
+ install = luatools-wine.install
+ arch = any
+ license = unknow
+ depends = wine
+ depends = winetricks
+ depends = wqy-zenhei
+ optdepends = wine-mono-gecko-version-fix: Fix the version numbers of wine-mono and wine-gecko files to solve the dialog box that pops up when starting wine.
+ provides = luatools-wine
+ conflicts = luatools-wine
+ conflicts = luatools
+ replaces = jlcpcassit-bin
+ options = !strip
+ source = luatools.exe::http://cdndownload.openluat.com/Luat_tool_src/v2tools/exe/exe_2_1_17.exe
+ source = http://www.openluat.com/Product/file/asr1802/AirM2M_USB_Download&Com_Driver_for_4G_V1.0.0.4.7z
+ source = luatools.svg::https://www.openluat.com/static/logo.0ced3f97.svg
+ source = luatools-wine.install
+ sha256sums = 4653eb360899714cdcf9d466a38a5378bac1b21e0e99e37cb88b189fd768421b
+ sha256sums = d68a23e640ae125b8a70821f3ff4b4aa998031c9373cae1b54bf34d11c316f2a
+ sha256sums = ba8836a40c11d432e6cabfee2a8792d44b1f3b56f0db77680a4f73511da1899c
+ sha256sums = 025d5f294f258a9d36334a610a0348ef3f084bba1e70c61cb0f7fea4b43f8e5a
+
+pkgname = luatools-wine
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37bb465dc2db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1704a6b46eff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,128 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=luatools-wine
+pkgver=2_1_17
+pkgrel=1
+pkgdesc="Wine LuatTools 是合宙的 Lua 调试工具"
+arch=('any')
+url="https://doc.openluat.com/wiki/3?wiki_page_id=694"
+license=('unknow')
+provides=(${pkgname})
+conflicts=(${pkgname} ${pkgname%-wine})
+replaces=("jlcpcassit-bin")
+depends=('wine' 'winetricks' 'wqy-zenhei')
+#makedepends=('innoextract')
+optdepends=("wine-mono-gecko-version-fix: Fix the version numbers of wine-mono and wine-gecko files to solve the dialog box that pops up when starting wine.")
+backup=()
+options=('!strip')
+install=${pkgname}.install
+source=("${pkgname%-wine}.exe::http://cdndownload.openluat.com/Luat_tool_src/v2tools/exe/exe_${pkgver}.exe"
+# "http://www.openluat.com/Product/file/uis8910dm/sw_file_20200303181718_8910_module_usb_driver_signed%20_20200303_hezhou.7z"
+ "http://www.openluat.com/Product/file/asr1802/AirM2M_USB_Download&Com_Driver_for_4G_V1.0.0.4.7z"
+ "${pkgname%-wine}.svg::https://www.openluat.com/static/logo.0ced3f97.svg"
+ "${pkgname}.install")
+sha256sums=('4653eb360899714cdcf9d466a38a5378bac1b21e0e99e37cb88b189fd768421b'
+ 'd68a23e640ae125b8a70821f3ff4b4aa998031c9373cae1b54bf34d11c316f2a'
+ 'ba8836a40c11d432e6cabfee2a8792d44b1f3b56f0db77680a4f73511da1899c'
+ '025d5f294f258a9d36334a610a0348ef3f084bba1e70c61cb0f7fea4b43f8e5a')
+#noextract=("${pkgname-wine}_${pkgver}.zip")
+
+prepare() {
+ _ftname="wqy-zenhei.ttc"
+ install -Dm0644 /dev/stdin "${srcdir}/regpatch.reg" << EOF
+REGEDIT4
+
+[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink]
+"Lucida Sans Unicode"="${_ftname}"
+"Microsoft Sans Serif"="${_ftname}"
+"MS Sans Serif"="${_ftname}"
+"Tahoma"="${_ftname}"
+"Tahoma Bold"="${_ftname}"
+"SimSun"="${_ftname}"
+"Arial"="${_ftname}"
+"Arial Black"="${_ftname}"
+"Lucida Sans Unicode"=str(7):"${_ftname}"
+"Microsoft Sans Serif"=str(7):"${_ftname}"
+"Tahoma"=str(7):"${_ftname}"
+
+[HKEY_CURRENT_USER\Software\Wine\X11 Driver]
+"ClientSideAntiAliasWithCore"="N"
+"ClientSideAntiAliasWithRender"="N"
+"ClientSideWithRender"="N"
+
+[HKEY_CURRENT_USER\Control Panel\Desktop]
+"FontSmoothing"="2"
+"FontSmoothingType"=dword:00000002
+"FontSmoothingGamma"=dword:00000578
+"FontSmoothingOrientation"=dword:00000001
+
+[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion]
+"RegisteredOrganization"="${pkgname%-wine}"
+"RegisteredOwner"="${pkgname%-wine}"
+
+[HKEY_LOCAL_MACHINE\Software\Wine\Ports]
+"COM1"="/dev/ttyUSB0"
+"COM2"="/dev/ttyUSB1"
+"COM3"="/dev/ttyUSB2"
+"COM4"="/dev/ttyUSB3"
+"COM5"="/dev/ttyUSB4"
+"COM6"="/dev/ttyUSB5"
+"COM7"="/dev/ttyACM0"
+EOF
+}
+
+package() {
+ export LC_CTYPE="zh_CN.UTF-8"
+
+ _path="opt/openluat"
+ _app="${pkgname%-wine}"
+ _usb="driver"
+
+ install -dm0755 "${pkgdir}/${_path}/${_app}" \
+ "${pkgdir}/usr/share/pixmaps"
+
+ cp -r "${srcdir}/${pkgname%-wine}.exe" "${pkgdir}/${_path}/${_app}/${_app}.exe"
+ cp -r "${srcdir}/AirM2M_USB_Download&Com_Driver_for_4G_V1.0.0.4" "${pkgdir}/${_path}/${_usb}"
+ cp -r "${srcdir}/regpatch.reg" "${pkgdir}/${_path}/regpatch.reg"
+
+ install -Dm0644 "${srcdir}/${pkgname%-wine}.svg" "${pkgdir}/usr/share/pixmaps/${pkgname%-wine}.svg"
+
+ install -Dm0755 /dev/stdin "${pkgdir}/usr/bin/${pkgname}" << EOF
+#!/bin/bash
+export WINEARCH=win32 WINEPREFIX="$HOME/.${pkgname%-wine}/wine"
+
+if [ ! -d "$HOME"/.${pkgname%-wine} ] ; then
+ mkdir -p "$HOME"/.${pkgname%-wine}/wine || exit 1
+# winetricks win10
+ ln -s /${_path}/regpatch.reg "$HOME"/.${pkgname%-wine}/wine || exit 1
+ regedit "$HOME"/.${pkgname%-wine}/wine/regpatch.reg
+
+ ln -s /${_path}/${_app}/${_app}.exe "$HOME"/.${pkgname%-wine}/${pkgname} || exit 1
+ ln -s /${_path}/${_usb} "$HOME"/.${pkgname%-wine}/${_usb} || exit 1
+
+ wine "$HOME"/.${pkgname%-wine}/${_usb}/DrvInstaller.exe
+# winetricks -q python27
+# wineboot --update
+
+fi
+
+
+WINEDEBUG=+loaddll wine "$HOME"/.${pkgname%-wine}/${pkgname} "\$@"
+
+# wine "$HOME"/.${pkgname%-wine}/${pkgname} "\$@"
+EOF
+
+ install -Dm0644 /dev/stdin "${pkgdir}/usr/share/applications/${pkgname}.desktop" << EOF
+[Desktop Entry]
+Name=${pkgname}
+Name[zh_CN]=luatools
+Comment=${pkgdesc}
+Exec=${pkgname%-wine} %f
+Type=Application
+StartupNotify=true
+Categories=Tool;Lua
+Terminal=false
+Icon=${pkgname%-wine}.svg
+Version=${pkgver}
+EOF
+}
diff --git a/luatools-wine.install b/luatools-wine.install
new file mode 100644
index 000000000000..08fbc71ba0f8
--- /dev/null
+++ b/luatools-wine.install
@@ -0,0 +1,17 @@
+# luatools-wine.post_install
+
+info() {
+ echo -e "Wine LuatTools 是合宙的 Lua 调试工具"
+}
+post_install() {
+ info
+}
+post_upgrade() {
+ info
+ echo "deleting the luatools bottle..."
+ find /home -maxdepth 2 -name ".luatools" -exec rm -rf {} \;
+}
+pre_remove() {
+ echo "deleting the luatools bottle..."
+ find /home -maxdepth 2 -name ".luatools" -exec rm -rf {} \;
+}