summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrinkerVII2022-06-05 00:29:21 +0200
committerBrinkerVII2022-06-05 00:29:21 +0200
commitdabe50857dcb49b4508dc9874a6b7ef1044da6cb (patch)
tree09f99b05bf1dc3aca6dbe6315df340c53c265d4d
parent8c13284de2181ed4b6d3ecbd143bd989252f348b (diff)
downloadaur-dabe50857dcb49b4508dc9874a6b7ef1044da6cb.tar.gz
Version 0.530
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Include-utility.patch24
-rw-r--r--PKGBUILD24
3 files changed, 47 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acfeab275803..12ce9cd94041 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luau-git
pkgdesc = A fast, small, safe, gradually typed embeddable scripting language derived from Lua
- pkgver = 0.501.dc83543
- pkgrel = 3
+ pkgver = 0.530.55a0268
+ pkgrel = 1
url = https://github.com/Roblox/luau
arch = any
license = MIT
@@ -11,6 +11,8 @@ pkgbase = luau-git
conflicts = luau
conflicts = luau-bin
source = git+https://github.com/Roblox/luau.git
+ source = 0001-Include-utility.patch
sha512sums = SKIP
+ sha512sums = 430480ea8d40db9f8f60419bc6e317f72b5718ff830877f676313e1d64906ef5168d51bd9a45c816cfb74c6f4838034b84661b4737a84daf1ad6d4988024c372
pkgname = luau-git
diff --git a/0001-Include-utility.patch b/0001-Include-utility.patch
new file mode 100644
index 000000000000..69e9e669af82
--- /dev/null
+++ b/0001-Include-utility.patch
@@ -0,0 +1,24 @@
+From 0cf89b611f53efc66b28df58cc0ebeec7c10a801 Mon Sep 17 00:00:00 2001
+From: BrinkerVII <brinkervii@gmail.com>
+Date: Sun, 5 Jun 2022 00:19:07 +0200
+Subject: [PATCH] Include <utility>
+
+---
+ Analysis/include/Luau/Variant.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Analysis/include/Luau/Variant.h b/Analysis/include/Luau/Variant.h
+index c9c97c9..f637222 100644
+--- a/Analysis/include/Luau/Variant.h
++++ b/Analysis/include/Luau/Variant.h
+@@ -6,6 +6,7 @@
+ #include <type_traits>
+ #include <initializer_list>
+ #include <stddef.h>
++#include <utility>
+
+ namespace Luau
+ {
+--
+2.36.1
+
diff --git a/PKGBUILD b/PKGBUILD
index ac80118c9a3c..6e590465eb41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgbase=luau
pkgname=luau-git
-pkgver=0.501.2f7e1a2
-pkgrel=2
+pkgver=0.530.55a0268
+pkgrel=1
pkgdesc='A fast, small, safe, gradually typed embeddable scripting language derived from Lua'
arch=('any')
@@ -14,19 +14,33 @@ makedepends=('git' 'cmake')
conflicts=("$_pkgbase" "$_pkgbase"-bin)
provides=("$_pkgbase")
-source=('git+https://github.com/Roblox/luau.git')
+source=(
+ 'git+https://github.com/Roblox/luau.git'
+ '0001-Include-utility.patch'
+)
-sha512sums=('SKIP')
+sha512sums=(
+ 'SKIP'
+ 430480ea8d40db9f8f60419bc6e317f72b5718ff830877f676313e1d64906ef5168d51bd9a45c816cfb74c6f4838034b84661b4737a84daf1ad6d4988024c372
+)
pkgver() {
- cd "$srcdir/$_pkgbase"
+ pushd "$srcdir/$_pkgbase" > /dev/null
_latest_tag=$(git describe --abbrev=0 --tags)
_git_hash=$(git rev-parse --short HEAD)
+
+ popd > /dev/null
echo "$_latest_tag.$_git_hash"
}
+prepare() {
+ pushd "$srcdir/$_pkgbase"
+ patch -p1 < "$srcdir/0001-Include-utility.patch"
+ popd
+}
+
build() {
_build_dir=$srcdir/build