summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-04-23 17:07:14 +0200
committerGeorg Schlisio2016-04-23 17:07:14 +0200
commit0c8eb5efc2d356619ec5af9fd09f2b83ad26e0b3 (patch)
tree544e72664b86d4ae6c3f2532ace4a52e5dbc1c4a
downloadaur-0c8eb5efc2d356619ec5af9fd09f2b83ad26e0b3.tar.gz
ver 2016.01.10, initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--luaunbound.install5
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c14f86afcd4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = luaunbound
+ pkgdesc = drop-in replacement for Prosodys internal DNS library with a binding to libunbound
+ pkgver = 2016.01.10
+ pkgrel = 1
+ url = https://www.zash.se/luaunbound.html
+ install = luaunbound.install
+ arch = i686
+ arch = x86_64
+ license = custom:MIT
+ makedepends = mercurial
+ makedepends = unbound
+ makedepends = lua
+ depends = unbound
+ optdepends = luajit: jit for lua
+ source = luaunbound::hg+https://code.zash.se/luaunbound
+ sha512sums = SKIP
+
+pkgname = luaunbound
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50061969a72c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: fordprefect <fordprefect@dukun.de>
+pkgname=luaunbound
+pkgver=2016.01.10
+pkgrel=1
+pkgdesc="drop-in replacement for Prosodys internal DNS library with a binding to libunbound"
+url="https://www.zash.se/luaunbound.html"
+arch=('i686' 'x86_64')
+license=('custom:MIT')
+depends=("unbound")
+makedepends=("mercurial" "unbound" "lua")
+optdepends=("luajit: jit for lua")
+install=luaunbound.install
+source=("${pkgname}::hg+https://code.zash.se/luaunbound")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ # fixed commit
+ hg checkout f270a1cf86ce
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./squish.sh > use_unbound.lua
+ unset LDFLAGS
+ make lunbound.so
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 use_unbound.lua "$pkgdir/etc/prosody/use_unbound.lua"
+ install -Dm755 lunbound.so "$pkgdir/usr/lib/prosody/util/lunbound.so"
+ install -Dm644 README.markdown "$pkgdir/usr/share/doc/luaunbound/README"
+ install -Dm444 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/luaunbound.install b/luaunbound.install
new file mode 100644
index 000000000000..0ef12fffe86c
--- /dev/null
+++ b/luaunbound.install
@@ -0,0 +1,5 @@
+post_install(){
+ echo "To enable luaunbound, add the following to the global section of your `prosody.cfg.lua`:"
+ echo 'RunScript "use\_unbound.lua"'
+ echo "More config info can be found in /usr/share/doc/luaunbound/README"
+}