summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2018-09-06 17:43:55 +0200
committerfordprefect2018-09-06 17:43:55 +0200
commit698560c7bff9f51ab1d80474395f428bfe8c7453 (patch)
tree4135582b9a87764ac59843eb92a52a29dd6b63a2
parentbfd87b961bc6606164e8e865a63c5aec70c49cd8 (diff)
downloadaur-698560c7bff9f51ab1d80474395f428bfe8c7453.tar.gz
0.2_1, new epoch due to new version scheme and move to more alive github upstream
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 308d0ae08198..09a9f6b1a997 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Sep 6 15:25:21 UTC 2018
+# Thu Sep 6 15:43:13 UTC 2018
pkgbase = luaunbound
pkgdesc = drop-in replacement for Prosodys internal DNS library with a binding to libunbound
- pkgver = 2017.11.15
- pkgrel = 3
+ pkgver = 0.2_1
+ pkgrel = 1
+ epoch = 1
url = https://www.zash.se/luaunbound.html
install = luaunbound.install
arch = i686
@@ -16,7 +17,7 @@ pkgbase = luaunbound
makedepends = ccache
depends = unbound
optdepends = luajit: jit for lua
- source = luaunbound::hg+https://code.zash.se/luaunbound
+ source = luaunbound-0.2_1.tar.gz::https://github.com/LuaDist2/luaunbound/archive/0.2-1.tar.gz
source = use_cc.patch
sha512sums = SKIP
sha512sums = 6b11dfe9f5de743f101463fb3fb2144fe3aff75e7e19036f67d0e0b8adc8c36db73cf73d0aba483d651f8f5b2773093adc27e788354b165314c777e8de45bf28
diff --git a/PKGBUILD b/PKGBUILD
index 0aff0e72497c..8af45ab56dbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: fordprefect <fordprefect@dukun.de>
# Contributor: jhass <me@jhass.eu>
pkgname=luaunbound
-pkgver=2017.11.15
-_version=5bd8a2f84124
-pkgrel=3
+pkgver=0.2_1
+_pkgver=0.2-1
+epoch=1
+pkgrel=1
pkgdesc="drop-in replacement for Prosodys internal DNS library with a binding to libunbound"
url="https://www.zash.se/luaunbound.html"
arch=('i686' 'x86_64')
@@ -12,24 +13,22 @@ depends=("unbound")
makedepends=("mercurial" "unbound" "lua" "libxslt" "ccache")
optdepends=("luajit: jit for lua")
install=luaunbound.install
-source=("${pkgname}::hg+https://code.zash.se/luaunbound" "use_cc.patch")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/LuaDist2/luaunbound/archive/${_pkgver}.tar.gz" "use_cc.patch")
sha512sums=('SKIP'
'6b11dfe9f5de743f101463fb3fb2144fe3aff75e7e19036f67d0e0b8adc8c36db73cf73d0aba483d651f8f5b2773093adc27e788354b165314c777e8de45bf28')
prepare() {
- cd "$srcdir/$pkgname"
- # fixed commit
- hg checkout $_version
+ cd "$srcdir/$pkgname-$_pkgver"
patch -p1 < "$srcdir/use_cc.patch"
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$_pkgver"
make all
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$_pkgver"
install -Dm644 use_unbound.lua "$pkgdir/etc/prosody/use_unbound.lua"
install -Dm755 lunbound.so "$pkgdir/usr/lib/prosody/util/lunbound.so"
install -Dm644 README.markdown "$pkgdir/usr/share/doc/luaunbound/README"