summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-06-28 21:24:28 +0200
committerGeorg Schlisio2016-06-28 21:24:28 +0200
commitab09e47bd9769519fc4a73e98712b684ca378dca (patch)
treee0b917e03d4c334a43810dc61b9a6d5aed524d92
parent892e7533d4190dd1f532941e6a0dbb9dd39ff34c (diff)
downloadaur-ab09e47bd9769519fc4a73e98712b684ca378dca.tar.gz
improvements from jhass added
-rw-r--r--PKGBUILD13
-rw-r--r--use_cc.patch12
2 files changed, 19 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afbf8d9e23b9..60f4edba3627 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: fordprefect <fordprefect@dukun.de>
+# Contributor: jhass <me@jhass.eu>
pkgname=luaunbound
pkgver=2016.01.10
-pkgrel=2
+pkgrel=3
pkgdesc="drop-in replacement for Prosodys internal DNS library with a binding to libunbound"
url="https://www.zash.se/luaunbound.html"
arch=('i686' 'x86_64')
@@ -10,20 +11,20 @@ depends=("unbound")
makedepends=("mercurial" "unbound" "lua")
optdepends=("luajit: jit for lua")
install=luaunbound.install
-source=("${pkgname}::hg+https://code.zash.se/luaunbound")
-sha512sums=('SKIP')
+source=("${pkgname}::hg+https://code.zash.se/luaunbound" "use_cc.patch")
+sha512sums=('SKIP'
+ '6b11dfe9f5de743f101463fb3fb2144fe3aff75e7e19036f67d0e0b8adc8c36db73cf73d0aba483d651f8f5b2773093adc27e788354b165314c777e8de45bf28')
prepare() {
cd "$srcdir/$pkgname"
# fixed commit
hg checkout f270a1cf86ce
+ patch -p1 < "$srcdir/use_cc.patch"
}
build() {
cd "$srcdir/$pkgname"
- ./squish.sh > use_unbound.lua
- unset LDFLAGS
- make lunbound.so
+ make all
}
package() {
diff --git a/use_cc.patch b/use_cc.patch
new file mode 100644
index 000000000000..85ffab9b3e42
--- /dev/null
+++ b/use_cc.patch
@@ -0,0 +1,12 @@
+diff -r f270a1cf86ce Makefile
+--- a/Makefile Sun Jan 10 19:49:52 2016 +0100
++++ b/Makefile Mon Jun 20 15:34:28 2016 +0200
+@@ -33,7 +33,7 @@
+ xsltproc root-anchors.xsl root-anchors.xml > $@
+
+ %.so: %.o
+- $(LD) $(LDFLAGS) -o $@ $^ $(LDLIBS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LDLIBS)
+
+ install:
+ install -d $(DESTDIR)$(LUA_LIBDIR)/