summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2018-09-06 17:26:09 +0200
committerfordprefect2018-09-06 17:26:09 +0200
commitbfd87b961bc6606164e8e865a63c5aec70c49cd8 (patch)
tree65407ef9bc63ab73e74645ebf61bfc20996d1328
parentad5907d4936a84a2315739b2be69208c76575def (diff)
downloadaur-bfd87b961bc6606164e8e865a63c5aec70c49cd8.tar.gz
revert
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 21 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d80c56feee0b..308d0ae08198 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Sep 6 15:12:49 UTC 2018
+# Thu Sep 6 15:25:21 UTC 2018
pkgbase = luaunbound
pkgdesc = drop-in replacement for Prosodys internal DNS library with a binding to libunbound
- pkgver = 1.7.3
- pkgrel = 1
- epoch = 1
+ pkgver = 2017.11.15
+ pkgrel = 3
url = https://www.zash.se/luaunbound.html
install = luaunbound.install
arch = i686
@@ -16,11 +15,10 @@ pkgbase = luaunbound
makedepends = libxslt
makedepends = ccache
depends = unbound
- depends = expat
optdepends = luajit: jit for lua
- source = luaunbound-1.7.3.tar.gz::https://github.com/NLnetLabs/unbound/archive/release-1.7.3.tar.gz
+ source = luaunbound::hg+https://code.zash.se/luaunbound
source = use_cc.patch
- sha512sums = ec25b1617a83e543ef61e10f01741af61e9af671c2d585b3953e17140c36f4defa46cee6bb0e588a3e65404a8ddc86b08f015037d91b92ba8a5bb3d13274018a
+ sha512sums = SKIP
sha512sums = 6b11dfe9f5de743f101463fb3fb2144fe3aff75e7e19036f67d0e0b8adc8c36db73cf73d0aba483d651f8f5b2773093adc27e788354b165314c777e8de45bf28
pkgname = luaunbound
diff --git a/PKGBUILD b/PKGBUILD
index 54f2b1a655aa..0aff0e72497c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,37 @@
# Maintainer: fordprefect <fordprefect@dukun.de>
# Contributor: jhass <me@jhass.eu>
pkgname=luaunbound
-pkgver=1.7.3
-epoch=1
-pkgrel=1
+pkgver=2017.11.15
+_version=5bd8a2f84124
+pkgrel=3
pkgdesc="drop-in replacement for Prosodys internal DNS library with a binding to libunbound"
url="https://www.zash.se/luaunbound.html"
arch=('i686' 'x86_64')
license=('custom:MIT')
-depends=("unbound" "expat")
+depends=("unbound")
makedepends=("mercurial" "unbound" "lua" "libxslt" "ccache")
optdepends=("luajit: jit for lua")
install=luaunbound.install
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/NLnetLabs/unbound/archive/release-${pkgver}.tar.gz" "use_cc.patch")
-sha512sums=('ec25b1617a83e543ef61e10f01741af61e9af671c2d585b3953e17140c36f4defa46cee6bb0e588a3e65404a8ddc86b08f015037d91b92ba8a5bb3d13274018a'
+source=("${pkgname}::hg+https://code.zash.se/luaunbound" "use_cc.patch")
+sha512sums=('SKIP'
'6b11dfe9f5de743f101463fb3fb2144fe3aff75e7e19036f67d0e0b8adc8c36db73cf73d0aba483d651f8f5b2773093adc27e788354b165314c777e8de45bf28')
prepare() {
- cd "$srcdir/unbound-release-$pkgver"
- #patch -p1 < "$srcdir/use_cc.patch"
+ cd "$srcdir/$pkgname"
+ # fixed commit
+ hg checkout $_version
+ patch -p1 < "$srcdir/use_cc.patch"
}
build() {
- cd "$srcdir/unbound-release-$pkgver"
- ./configure --enable-pie
- make
+ cd "$srcdir/$pkgname"
+ make all
}
package() {
- cd "$srcdir/unbound-release-$pkgver"
- make DESTDIR="$pkgdir" \
- prefix="/usr" \
- exec_prefix="/usr" \
- configfile="/etc/unbound/unbound.conf" \
- sbindir="/usr/bin" \
- install
- install -Dm644 doc/README "$pkgdir/usr/share/doc/luaunbound/README"
+ cd "$srcdir/$pkgname"
+ install -Dm644 use_unbound.lua "$pkgdir/etc/prosody/use_unbound.lua"
+ install -Dm755 lunbound.so "$pkgdir/usr/lib/prosody/util/lunbound.so"
+ install -Dm644 README.markdown "$pkgdir/usr/share/doc/luaunbound/README"
install -Dm444 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}