summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authori3master2022-12-20 15:05:26 -0600
committeri3master2022-12-20 15:05:26 -0600
commitee010f4409416f3e8e093fac324a6e5febe5355f (patch)
tree4cbaec98860b025d975e1566fbf146e0428cdccc
downloadaur-ee010f4409416f3e8e093fac324a6e5febe5355f.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7a07aadabdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lubuntu-artwork-18-04
+ pkgdesc = Lubuntu 18.04 default GTK theme, icons, and wallpapers
+ pkgver = 0.71
+ pkgrel = 1
+ url = http://wiki.ubuntu.com/Lubuntu/Artwork
+ arch = any
+ license = GPL
+ optdepends = elementary-icon-theme: icons support
+ optdepends = gtk-engine-unico: gtk3 theme support
+ conflicts = lubuntu-artwork
+ source = http://archive.ubuntu.com/ubuntu/pool/universe/l/lubuntu-artwork/lubuntu-artwork_0.71.tar.xz
+ sha256sums = 5374c5a5cf12a439f17ec336db11ccaa6a620e9ad79c5ed9a39c02088189a285
+
+pkgname = lubuntu-artwork-18-04
+ depends = gtk-engine-murrine
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..5f342834e8f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: i3master <fast dot code dot studio at gmail dot com>
+# Tip: To use this theme in LXDE, select 'Lubuntu-default' from the list in lxappearance under the 'Widget' tab, 'Icon Theme' tab, and 'Window Border' tab.
+
+# Note: This was forked from lubuntu-artwork to preserve the Lubuntu 18.04 theme, icons, and wallpapers for LXDE before they changed in 18.10.
+# The original maintainers and contributers are listed below (from lubuntu-default).
+# Original Maintainer: Nissar Chababy <funilrys at outlook dot com>
+# Original Ex-Maintainer: lestb <tkhdlstfl dot l plus aur at gmail dot com>
+# Original Contributor: 謝致邦<Yeking@Red54.com>
+
+pkgname=lubuntu-artwork-18-04
+_archivename=lubuntu-artwork
+pkgver=0.71
+pkgrel=1
+pkgdesc='Lubuntu 18.04 default GTK theme, icons, and wallpapers'
+arch=('any')
+url='http://wiki.ubuntu.com/Lubuntu/Artwork'
+license=('GPL')
+optdepends=('elementary-icon-theme: icons support'
+ 'gtk-engine-unico: gtk3 theme support')
+source=("http://archive.ubuntu.com/ubuntu/pool/universe/l/${_archivename}/${_archivename}_${pkgver}.tar.xz")
+sha256sums=('5374c5a5cf12a439f17ec336db11ccaa6a620e9ad79c5ed9a39c02088189a285')
+conflicts=("lubuntu-artwork")
+
+package(){
+ # Some apps in LXDE (including lxappearance) don't look right until gtk-engine-murrine is installed.
+ depends=('gtk-engine-murrine')
+
+ cp -r "${srcdir}/${_archivename}/src/usr" "${pkgdir}"
+}