summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-07-22 16:48:27 +0800
committerzxp198210052024-07-22 16:48:27 +0800
commite0c3448904e8da62a8db8a0fe15cec80d4f4f567 (patch)
tree0f6ea17584d7d4648caa59e6d9cc5cb2c1abb682
parenta5e9250bbaa35386aa10137ee9eeae074dbb4c91 (diff)
downloadaur-e0c3448904e8da62a8db8a0fe15cec80d4f4f567.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--lucashazardous-music-player.sh4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 029d72fae5a6..c2593841c256 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lucashazardous-music-player-bin
pkgdesc = Desktop Electron app for playing and downloading music.
pkgver = 2.12.5
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/LucasHazardous/music-player
arch = x86_64
license = MIT
@@ -14,6 +14,6 @@ pkgbase = lucashazardous-music-player-bin
source = lucashazardous-music-player.sh
sha256sums = 3b3ef8988b2365c0baae8a6832bf4985981d24deaa4c97e8fa2c919df93e7cfb
sha256sums = 4de62e75233b269ff4b9e1bf7ba805d82bd3cbeab4c204b54043dee4965f849c
- sha256sums = 41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d
+ sha256sums = 2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051
pkgname = lucashazardous-music-player-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2ef05a843f18..2d7d5397267e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _pkgname=music-player
pkgname="lucashazardous-${_pkgname}-bin"
pkgver=2.12.5
_electronversion=26
-pkgrel=6
+pkgrel=7
pkgdesc="Desktop Electron app for playing and downloading music."
arch=('x86_64')
url="https://github.com/LucasHazardous/music-player"
@@ -23,7 +23,7 @@ source=(
)
sha256sums=('3b3ef8988b2365c0baae8a6832bf4985981d24deaa4c97e8fa2c919df93e7cfb'
'4de62e75233b269ff4b9e1bf7ba805d82bd3cbeab4c204b54043dee4965f849c'
- '41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d')
+ '2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/lucashazardous-music-player.sh b/lucashazardous-music-player.sh
index 398398461fee..4cfe3ac09dd8 100644
--- a/lucashazardous-music-player.sh
+++ b/lucashazardous-music-player.sh
@@ -23,7 +23,7 @@ if [[ -f "${_FLAGS_FILE}" ]]; then
fi
cd "${_APPDIR}"
if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS[@]}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} "${_USER_FLAGS[@]}" "$@"
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS[@]}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} --no-sandbox "${_USER_FLAGS[@]}" "$@"
fi \ No newline at end of file