summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergii Fesenko2021-05-23 13:06:21 +0300
committerSergii Fesenko2021-05-23 13:07:25 +0300
commit08d96b3c7be87ec3699722f8d1c99294c2a666fd (patch)
tree72959b133e0fdf0c80f74df698c8625dc640e71b
downloadaur-08d96b3c7be87ec3699722f8d1c99294c2a666fd.tar.gz
Create package
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5783f7ed8a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lucene-grep
+ pkgdesc = Grep-like utility based on Lucene Monitor compiled with GraalVM native-image
+ pkgver = v2021.05.02
+ pkgrel = 1
+ url = https://github.com/dainiusjocas/lucene-grep
+ arch = x86_64
+ license = APACHE
+ conflicts = lucene-grep-git
+ source = https://github.com/dainiusjocas/lucene-grep/releases/download/v2021.05.02/lmgrep-v2021.05.02-linux-static-amd64.zip
+ sha256sums = 42a7bba27d8fce89ff049acf14e61ac7a70ab6a874875972c2366ea6b39a107a
+
+pkgname = lucene-grep
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9618944488b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+
+#
+lmgrep*
+lucene-grep-*.tar.???
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4152464de5c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Sergii Fesenko <sergii_f@outlook.com>
+
+
+pkgname=lucene-grep
+pkgver=v2021.05.02
+pkgrel=1
+pkgdesc="Grep-like utility based on Lucene Monitor compiled with GraalVM native-image"
+arch=(x86_64)
+url="https://github.com/dainiusjocas/lucene-grep"
+license=('APACHE')
+conflicts=(lucene-grep-git)
+source=("https://github.com/dainiusjocas/lucene-grep/releases/download/${pkgver}/lmgrep-${pkgver}-linux-static-amd64.zip")
+sha256sums=('42a7bba27d8fce89ff049acf14e61ac7a70ab6a874875972c2366ea6b39a107a')
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install -m755 -D lmgrep "$pkgdir"/usr/bin/lmgrep
+}