summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergii Fesenko2022-08-09 10:21:08 +0300
committerSergii Fesenko2022-08-09 10:21:08 +0300
commitccaeb3cb71e26891f897c413b3cb0e8fc35f37bd (patch)
treed4359bc5cadb11b7d8c7f16053e26038a3c4896a
parent210fd169c8ed4958a17138f1b2d949a1e982a232 (diff)
downloadaur-lucene-grep-git.tar.gz
Use jdk17 graalvm
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c6c85c65ba2..f40263a2adff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lucene-grep-git
pkgdesc = Grep-like utility based on Lucene Monitor compiled with GraalVM native-image
- pkgver = 2021.05.23.1.gfc9c49a
+ pkgver = 2022.07.27.3.g944f12f
pkgrel = 1
url = https://github.com/dainiusjocas/lucene-grep
arch = i686
@@ -9,7 +9,8 @@ pkgbase = lucene-grep-git
makedepends = git
makedepends = make
makedepends = clojure
- makedepends = native-image-jdk11-bin
+ makedepends = jdk17-graalvm-bin
+ makedepends = native-image-jdk17-bin
depends = zlib
provides = lucene-grep
conflicts = lucene-grep
@@ -17,4 +18,3 @@ pkgbase = lucene-grep-git
md5sums = SKIP
pkgname = lucene-grep-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 97865cacd2eb..3d6e87c65f03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Sergii Fesenko <sergii_f@outlook.com>
pkgname=lucene-grep-git
-_pkgname=lucene-grep
-pkgver=2021.05.23.1.gfc9c49a
+pkgver=2022.07.27.3.g944f12f
pkgrel=1
pkgdesc="Grep-like utility based on Lucene Monitor compiled with GraalVM native-image"
arch=(i686 x86_64)
@@ -11,26 +10,32 @@ license=('APACHE')
conflicts=(lucene-grep)
provides=(lucene-grep)
depends=(zlib)
-makedepends=(git make clojure native-image-jdk11-bin)
+makedepends=(
+ git
+ make
+ clojure
+ jdk17-graalvm-bin
+ native-image-jdk17-bin)
source=('git+https://github.com/dainiusjocas/lucene-grep.git')
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${pkgname%-git}"
git describe --tags --long | sed 's/-/./g; s/-g/./; s/^v//'
}
build() {
- cd "$srcdir/$_pkgname"
- GRAALVM_HOME=/usr/lib/jvm/java-11-graalvm make build
+ cd "${pkgname%-git}"
+ GRAALVM_HOME=/usr/lib/jvm/java-17-graalvm \
+ make build
}
package() {
+ cd "${pkgname%-git}"
+
mkdir -p $pkgdir/usr/bin
mkdir -p $pkgdir/usr/share/licenses/$pkgname/
- cd $srcdir/$_pkgname
cp LICENSE $pkgdir/usr/share/licenses/$pkgname/
install -D lmgrep "$pkgdir"/usr/bin/lmgrep
}
-