summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergii Fesenko2021-05-01 13:47:47 +0300
committerSergii Fesenko2021-05-01 13:47:47 +0300
commit7109cc120666c7ba7917393a4651ff68ea05a9a2 (patch)
tree8097a084e0447ee8276d55390de59b97dc137407
downloadaur-7109cc120666c7ba7917393a4651ff68ea05a9a2.tar.gz
create package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9816a35f844
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lucene-grep-git
+ pkgdesc = Grep-like utility based on Lucene Monitor compiled with GraalVM native-image
+ pkgver = v2021.04.26.r6.a00056d
+ pkgrel = 1
+ url = https://github.com/dainiusjocas/lucene-grep
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = make
+ makedepends = clojure
+ depends = zlib
+ conflicts = lucene-grep
+ source = git+https://github.com/dainiusjocas/lucene-grep.git
+ md5sums = SKIP
+
+pkgname = lucene-grep-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db856aac265c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sergii Fesenko <sergii_f@outlook.com>
+
+pkgname=lucene-grep-git
+_pkgname=lucene-grep
+pkgver=v2021.04.26.r6.a00056d
+pkgrel=1
+pkgdesc="Grep-like utility based on Lucene Monitor compiled with GraalVM native-image"
+arch=(i686 x86_64)
+url="https://github.com/dainiusjocas/lucene-grep"
+license=('APACHE')
+conflicts=(lucene-grep)
+depends=('zlib')
+makedepends=('git' 'make' 'clojure')
+source=('git+https://github.com/dainiusjocas/lucene-grep.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --tags --long | sed 's/-/.r/; s/-g/./'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname/
+
+ cd $srcdir/$_pkgname
+ cp LICENSE $pkgdir/usr/share/licenses/$pkgname/
+ install -D lmgrep "$pkgdir"/usr/bin/lmgrep
+}
+