summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAuguste Pop2015-06-11 16:37:47 +0800
committerAuguste Pop2015-06-11 16:37:47 +0800
commitecc61c7c4aadb8010f77a1749230f649a411b786 (patch)
tree990fb736be2b82099d602d8c576e585fb498e7a0
downloadaur-ecc61c7c4aadb8010f77a1749230f649a411b786.tar.gz
upgrade to 0.9.10
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--lucidor.install14
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa7da89075ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lucidor
+ pkgdesc = A program for reading and handling EPUB e-books and OPDS catalogs
+ pkgver = 0.9.10
+ pkgrel = 1
+ url = http://lucidor.org/lucidor/
+ install = lucidor.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = xulrunner
+ depends = desktop-file-utils
+ source = lucidor_0.9.10.tar.gz::http://lucidor.org/get.php?id=lucidor_0.9.10.tar.gz
+ md5sums = 8cc37d68bfd037d095057176bcd17dd8
+
+pkgname = lucidor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e831c7c0f41d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Auguste Pop <auguste [at] gmail [dot] com>
+
+pkgname=lucidor
+pkgver=0.9.10
+pkgrel=1
+pkgdesc="A program for reading and handling EPUB e-books and OPDS catalogs"
+arch=('i686' 'x86_64')
+url="http://lucidor.org/lucidor/"
+license=('GPL3')
+depends=('xulrunner' 'desktop-file-utils')
+install=$pkgname.install
+source=(${pkgname}_${pkgver}.tar.gz::"http://lucidor.org/get.php?id=${pkgname}_${pkgver}.tar.gz")
+md5sums=('8cc37d68bfd037d095057176bcd17dd8')
+
+build()
+{
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package()
+{
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
diff --git a/lucidor.install b/lucidor.install
new file mode 100644
index 000000000000..6079f16e3d85
--- /dev/null
+++ b/lucidor.install
@@ -0,0 +1,14 @@
+post_install()
+{
+ update-desktop-database -q
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+post_remove()
+{
+ post_install
+}