summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorianux2015-06-10 13:00:58 +0200
committerianux2015-06-10 13:00:58 +0200
commitd672e8a25db78c595e3eb85e0fdd02a2bcb6201a (patch)
treed855974c0e4e2b5273f74928af7727a77e9b59d6
downloadaur-luciole.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD27
-rw-r--r--luciole.install18
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fe5f449366d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = luciole
+ pkgdesc = Stop-motion software
+ pkgver = 0.9.3
+ pkgrel = 2
+ url = http://festival.inattendu.org/Luciole
+ install = luciole.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2-dbus
+ depends = gnome-python
+ depends = gstreamer0.10-base-plugins
+ depends = gstreamer0.10-good-plugins
+ depends = gstreamer0.10-python
+ depends = imagemagick
+ depends = mjpegtools
+ depends = python2
+ depends = pygtk
+ depends = python2-imaging
+ depends = python2-gudev
+ optdepends = ffmpeg: for export feature
+ optdepends = mencoder: for export feature
+ source = http://launchpad.net/luciole/0.9/0.9.3/+download/luciole-0.9.3.tar.gz
+ md5sums = a04ef1d9ea3e3071781f3c317e65845a
+ sha1sums = ec6a80eb697344387d02f6925cbf6526c06794d6
+
+pkgname = luciole
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a6686b1b96e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: ianux <ianux@free.fr>
+pkgname=luciole
+pkgver=0.9.3
+pkgrel=2
+pkgdesc="Stop-motion software"
+arch=('i686' 'x86_64')
+url="http://festival.inattendu.org/Luciole"
+license=('GPL')
+depends=('python2-dbus' 'gnome-python' 'gstreamer0.10-base-plugins' 'gstreamer0.10-good-plugins'
+ 'gstreamer0.10-python' 'imagemagick' 'mjpegtools' 'python2' 'pygtk' 'python2-imaging'
+ 'python2-gudev')
+optdepends=('ffmpeg: for export feature'
+ 'mencoder: for export feature')
+source=(http://launchpad.net/luciole/0.9/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz)
+md5sums=('a04ef1d9ea3e3071781f3c317e65845a')
+sha1sums=('ec6a80eb697344387d02f6925cbf6526c06794d6')
+install=${pkgname}.install
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+}
diff --git a/luciole.install b/luciole.install
new file mode 100644
index 000000000000..83fcde6d010f
--- /dev/null
+++ b/luciole.install
@@ -0,0 +1,18 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+op=$1
+shift
+
+$op $*
+
+