summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Cristofaro2018-05-12 20:26:40 +1000
committerDavid Cristofaro2018-05-12 20:26:40 +1000
commit76deb601a65d9c0e7eba42b70680ccec4912fb31 (patch)
tree8eac8eea8afefc57d3fd4d6f5d70b532e9efcaff
downloadaur-76deb601a65d9c0e7eba42b70680ccec4912fb31.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81f0cf31a2e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lucky-git
+ pkgdesc = A web framework written in Crystal that helps you build apps quickly, catches bugs for you, and runs incredibly fast
+ pkgver = 0.9.2.r25.gd33ffbc
+ pkgrel = 1
+ url = https://luckyframework.org/
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = crystal
+ depends = shards
+ provides = lucky
+ conflicts = lucky
+ source = git+https://github.com/luckyframework/lucky_cli.git
+ sha256sums = SKIP
+
+pkgname = lucky-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1010f790f8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: David Cristofaro <david@dtcristo.com>
+pkgname=lucky-git
+pkgver=0.9.2.r25.gd33ffbc
+pkgrel=1
+pkgdesc='A web framework written in Crystal that helps you build apps quickly, catches bugs for you, and runs incredibly fast'
+arch=('x86_64')
+url='https://luckyframework.org/'
+license=('MIT')
+depends=('crystal' 'shards')
+makedepends=('git')
+provides=('lucky')
+conflicts=('lucky')
+source=("git+https://github.com/luckyframework/lucky_cli.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "lucky_cli"
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "lucky_cli"
+ crystal deps
+ crystal build src/lucky.cr --release --no-debug
+}
+
+package() {
+ cd "lucky_cli"
+ install -Dm755 lucky "$pkgdir/usr/bin/lucky"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}