summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Cristofaro2018-11-07 13:41:57 +1100
committerDavid Cristofaro2018-11-07 13:41:57 +1100
commit97352988f5389cc32b14611315b0b0e4fcf41a33 (patch)
tree4e752474c6628c3771e4c6071d68a53b51982b06
parent0f84493199d3bd4c8d3b1efbebe784e84f6f17d9 (diff)
downloadaur-97352988f5389cc32b14611315b0b0e4fcf41a33.tar.gz
Update pkgver
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5392e802fef6..063acc4edb6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lucky-git
pkgdesc = A Crystal web framework that catches bugs for you, runs incredibly fast, and helps you write code that lasts.
- pkgver = 0.10.0.rc3.r22.gcc1333c
+ pkgver = 0.12.0.r4.3b9103d
pkgrel = 1
url = https://luckyframework.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 98f4e9c3af85..0e7f24752342 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: David Cristofaro <david@dtcristo.com>
pkgname=lucky-git
-pkgver=0.10.0.rc3.r22.gcc1333c
+pkgver=0.12.0.r4.3b9103d
pkgrel=1
pkgdesc='A Crystal web framework that catches bugs for you, runs incredibly fast, and helps you write code that lasts.'
arch=('x86_64')
@@ -14,18 +14,19 @@ source=('git+https://github.com/luckyframework/lucky_cli.git')
sha256sums=('SKIP')
pkgver() {
- cd lucky_cli
- git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "lucky_cli"
+ local tag=$(git rev-list --tags --max-count=1)
+ printf "%s.r%s.%s" "$(git describe --tags $tag | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')" "$(git rev-list --count $tag..)" "$(git rev-parse --short HEAD)"
}
build() {
- cd lucky_cli
+ cd "lucky_cli"
shards install
crystal build src/lucky.cr --release --no-debug
}
package() {
- cd lucky_cli
+ cd "lucky_cli"
install -Dm755 lucky "$pkgdir/usr/bin/lucky"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}