summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Cristofaro2018-05-29 12:00:15 +1000
committerDavid Cristofaro2018-05-29 12:00:15 +1000
commitd803989f009668f64e24c0b4efc99358a8c678cb (patch)
tree181a8c732e600811ef14c833e88f08bf2022d15d
parent76deb601a65d9c0e7eba42b70680ccec4912fb31 (diff)
downloadaur-d803989f009668f64e24c0b4efc99358a8c678cb.tar.gz
Update to 0.10.0
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81f0cf31a2e7..fb3d64f34e56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lucky-git
pkgdesc = A web framework written in Crystal that helps you build apps quickly, catches bugs for you, and runs incredibly fast
- pkgver = 0.9.2.r25.gd33ffbc
+ pkgver = 0.10.0.rc3.r5.gbecb039
pkgrel = 1
url = https://luckyframework.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b1010f790f8a..75ccaf8bf47a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: David Cristofaro <david@dtcristo.com>
pkgname=lucky-git
-pkgver=0.9.2.r25.gd33ffbc
+pkgver=0.10.0.rc3.r5.gbecb039
pkgrel=1
pkgdesc='A web framework written in Crystal that helps you build apps quickly, catches bugs for you, and runs incredibly fast'
arch=('x86_64')
@@ -10,22 +10,22 @@ depends=('crystal' 'shards')
makedepends=('git')
provides=('lucky')
conflicts=('lucky')
-source=("git+https://github.com/luckyframework/lucky_cli.git")
+source=('git+https://github.com/luckyframework/lucky_cli.git')
sha256sums=('SKIP')
pkgver() {
- cd "lucky_cli"
+ cd lucky_cli
git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "lucky_cli"
+ cd lucky_cli
crystal deps
crystal build src/lucky.cr --release --no-debug
}
package() {
- cd "lucky_cli"
+ cd lucky_cli
install -Dm755 lucky "$pkgdir/usr/bin/lucky"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}