summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Tryfonidis2015-06-27 16:41:53 +0300
committerTom Tryfonidis2015-06-27 16:41:53 +0300
commitfd77e0b4e62db1fba967e2fe0238b74fd1e61552 (patch)
treecb259c0a8f049a6d93243f5776adddfb9092b3e1
downloadaur-fd77e0b4e62db1fba967e2fe0238b74fd1e61552.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
-rw-r--r--luckybackup.install14
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b07dcaf1d58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = luckybackup
+ pkgdesc = Backup & Sync tool using Rsync and Qt4
+ pkgver = 0.4.8
+ pkgrel = 1
+ url = http://luckybackup.sourceforge.net/
+ install = luckybackup.install
+ arch = any
+ license = GPL3
+ depends = qt4
+ depends = rsync
+ depends = openssh
+ provides = luckybackup
+ conflicts = luckybackup-git
+ source = http://downloads.sourceforge.net/project/luckybackup/0.4.8/source/luckybackup-0.4.8.tar.gz
+ md5sums = f6dcf502c2f11b5d44837189bf00ee01
+
+pkgname = luckybackup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..745966e997c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Contributor: Tom Tryfonidis <tomtryf [at] gmail [dot] com>
+#Maintainer: Tom Tryfonidis <tomtryf [at] gmail [dot] com>
+
+pkgname=luckybackup
+pkgver=0.4.8
+pkgrel=1
+pkgdesc="Backup & Sync tool using Rsync and Qt4"
+arch=('any')
+url="http://luckybackup.sourceforge.net/"
+license=('GPL3')
+depends=( 'qt4' 'rsync' 'openssh')
+provides=('luckybackup')
+conflicts=('luckybackup-git')
+install=$pkgname.install
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz")
+md5sums=('f6dcf502c2f11b5d44837189bf00ee01')
+
+build() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/luckybackup.install b/luckybackup.install
new file mode 100644
index 000000000000..ecd5b94e20ad
--- /dev/null
+++ b/luckybackup.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+
+