summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEasyIP20232019-11-07 14:34:21 -0600
committerEasyIP20232019-11-07 14:34:21 -0600
commit9ae73f1e81499779354663078ff0327b5e6b0e55 (patch)
treebc8d65c61c895d22057ccec43dffacf62799bad2
parenta277104ddeb45d2b9a58a36f5cf40cc91d013596 (diff)
downloadaur-9ae73f1e81499779354663078ff0327b5e6b0e55.tar.gz
fix pkgver bug
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 193a2b219bfa..79cdf6b1f85d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,8 @@ pkgbase = lucurious-git
depends = vulkan-icd-loader
depends = cglm
depends = wayland
+ provides = lucurious=0.0.1
+ conflicts = lucurious
source = lucurious-git::git+https://github.com/EasyIP2023/lucurious
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d1288c80449d..e39219027572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,8 @@ license=('MIT')
pkgdesc='[Desktop Engine, Library] for building and styling 2D/3D Vulkan Wayland Compositors'
url='https://github.com/EasyIP2023/lucurious'
arch=('x86_64')
+provides=("lucurious=${pkgver%%.r*}")
+conflicts=('lucurious')
depends=('shaderc' 'vulkan-driver' 'vulkan-icd-loader' 'cglm' 'wayland')
makedepends=('meson' 'ninja' 'git' 'wayland-protocols' 'vulkan-headers' 'check')
source=("${pkgname}::git+${url}")
@@ -17,7 +19,7 @@ pkgver () {
(
set -o pipefail
git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "${pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}