summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2020-09-01 23:09:26 +0200
committerJulian Xhokaxhiu2020-09-01 23:12:48 +0200
commitbe404b956e605c3b75ccc68f2525c5e0d5ef131d (patch)
tree04b06b50213b5491759c2fd70af3dfd6ab2a66b2
downloadaur-be404b956e605c3b75ccc68f2525c5e0d5ef131d.tar.gz
0.11.2-1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD48
-rw-r--r--ludo.desktop12
-rw-r--r--ludo.json5
5 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a18607cb6d72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ludo-bin
+ pkgdesc = Ludo is a minimalist frontend for emulators
+ pkgver = 0.11.2
+ pkgrel = 1
+ url = https://github.com/libretro/ludo
+ arch = x86_64
+ arch = armv7h
+ license = GPL3
+ depends = glfw
+ depends = openal
+ depends = mesa
+ source = ludo.json
+ source = ludo.desktop
+ sha256sums = 89e860320694d3bec02942bb81af01a8553d5f49c4c50a2cbf377d6252b481a5
+ sha256sums = 139eedd5dd868717b46032cd9773bc63b692237c37e6da4450357a3f56a18042
+ source_x86_64 = ludo-bin-0.11.2.tar.gz::https://github.com/libretro/ludo/releases/download/v0.11.2/Ludo-Linux-x86_64-0.11.2.tar.gz
+ sha256sums_x86_64 = a287010e35d774c58bbbd435c9a7113bdb4b3463528a9e721ce1a79e62ff4335
+ source_armv7h = ludo-bin-0.11.2.tar.gz::https://github.com/libretro/ludo/releases/download/v0.11.2/Ludo-Linux-arm-0.11.2.tar.gz
+ sha256sums_armv7h = 974749909fe036ad8a74f61b6011469f5715de979cc362d8db045c43539e1ed6
+
+pkgname = ludo-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..816ed4de92db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Ignore everything
+*
+
+# ...but
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!ludo.desktop
+!ludo.json
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77c5b75ca4e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Julian Xhokaxhiu <info at julianxhokaxhiu dot com>
+pkgname=ludo-bin
+pkgver=0.11.2
+pkgrel=1
+pkgdesc="Ludo is a minimalist frontend for emulators"
+arch=('x86_64' 'armv7h')
+url="https://github.com/libretro/ludo"
+license=('GPL3')
+depends=(
+ 'glfw'
+ 'openal'
+ 'mesa'
+)
+source=(
+ "ludo.json"
+ "ludo.desktop"
+)
+source_x86_64=("${pkgname}-${pkgver}.tar.gz::https://github.com/libretro/ludo/releases/download/v${pkgver}/Ludo-Linux-x86_64-${pkgver}.tar.gz")
+source_armv7h=("${pkgname}-${pkgver}.tar.gz::https://github.com/libretro/ludo/releases/download/v${pkgver}/Ludo-Linux-arm-${pkgver}.tar.gz")
+sha256sums=(
+ '89e860320694d3bec02942bb81af01a8553d5f49c4c50a2cbf377d6252b481a5'
+ '139eedd5dd868717b46032cd9773bc63b692237c37e6da4450357a3f56a18042'
+)
+sha256sums_x86_64=('a287010e35d774c58bbbd435c9a7113bdb4b3463528a9e721ce1a79e62ff4335')
+sha256sums_armv7h=('974749909fe036ad8a74f61b6011469f5715de979cc362d8db045c43539e1ed6')
+
+package() {
+ _ARCH=""
+
+ if [ $arch == "armv7h" ]; then
+ _ARCH="arm"
+ else
+ _ARCH="$arch"
+ fi
+
+ install -Dm644 "ludo.json" "$pkgdir/etc/ludo.json"
+ install -Dm644 "ludo.desktop" "$pkgdir/usr/share/applications/ludo.desktop"
+
+ cd "$srcdir/Ludo-Linux-$_ARCH-$pkgver"
+
+ install -Dm755 "ludo" "$pkgdir/usr/bin/ludo"
+ install -Dm755 "assets/icon.svg" "$pkgdir/usr/share/pixmaps/ludo.svg"
+ install -dm755 "$pkgdir/usr/share/ludo"
+ cp -R "assets/" "$pkgdir/usr/share/ludo/assets"
+ cp -R "cores/" "$pkgdir/usr/share/ludo/cores"
+ cp -R "database/" "$pkgdir/usr/share/ludo/database"
+ chmod -R 0755 "$pkgdir/usr/share/ludo"
+}
diff --git a/ludo.desktop b/ludo.desktop
new file mode 100644
index 000000000000..b7a4b555e563
--- /dev/null
+++ b/ludo.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Name=Ludo
+GenericName=Ludo
+Type=Application
+Comment=Ludo is a work in progress libretro frontend written in go
+Icon=ludo
+Exec=ludo
+Terminal=false
+StartupNotify=false
+Keywords=multi;engine;emulator;xmb;
+Categories=Game;Emulator;
diff --git a/ludo.json b/ludo.json
new file mode 100644
index 000000000000..b9a6b7fa0461
--- /dev/null
+++ b/ludo.json
@@ -0,0 +1,5 @@
+{
+ "cores_dir": "/usr/share/ludo/cores",
+ "assets_dir": "/usr/share/ludo/assets",
+ "database_dir": "/usr/share/ludo/database"
+}