summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeanbon2017-01-08 20:33:57 +0100
committerJeanbon2017-01-08 20:33:57 +0100
commit2341005ca46754dbe93172d26282aa4578894ed9 (patch)
treec4ee6e81c97ffebef439377cb1af41a9ad843051
parenteff1625c8663ddd1d778402842d92405dc608676 (diff)
downloadaur-2341005ca46754dbe93172d26282aa4578894ed9.tar.gz
Improve file location
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f6f533886c1..9c62426aed8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Dec 26 19:00:30 UTC 2016
+# Sun Jan 8 19:33:49 UTC 2017
pkgbase = lugaru
pkgdesc = A third-person action game featuring a unique close-range combat system
pkgver = 1.1
- pkgrel = 1
+ pkgrel = 2
url = https://osslugaru.gitlab.io
arch = i686
arch = x86_64
@@ -17,6 +17,8 @@ pkgbase = lugaru
depends = libvorbis
depends = zlib
conflicts = lugaru-hg
+ conflicts = lugaruhd-hg
+ options = !optipng
source = lugaru-1.1.tar.bz2::https://gitlab.com/osslugaru/lugaru/repository/archive.tar.bz2?ref=1.1
source = lugaru.desktop
sha256sums = 4372ef81494365f7227a72051960f3940acf8418006dbdb05c83d12232f481e7
diff --git a/PKGBUILD b/PKGBUILD
index cda7bcd9b5bf..c538f6f79ad1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
pkgname=lugaru
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A third-person action game featuring a unique close-range combat system"
url="https://osslugaru.gitlab.io"
license=('GPL')
arch=('i686' 'x86_64')
depends=('sdl2' 'glu' 'libjpeg-turbo' 'libpng' 'openal' 'libvorbis' 'zlib')
makedepends=('cmake')
-conflicts=('lugaru-hg')
+options=('!optipng')
+conflicts=('lugaru-hg' 'lugaruhd-hg')
source=("${pkgname}-${pkgver}.tar.bz2::https://gitlab.com/osslugaru/lugaru/repository/archive.tar.bz2?ref=${pkgver}"
"${pkgname}.desktop")
sha256sums=('4372ef81494365f7227a72051960f3940acf8418006dbdb05c83d12232f481e7'
@@ -16,12 +17,14 @@ sha256sums=('4372ef81494365f7227a72051960f3940acf8418006dbdb05c83d12232f481e7'
build() {
cd $srcdir/lugaru-1.1-53bbd7b11ba7558692b00d936d3103750fcb430b/
- mkdir build
+ mkdir build || true
cd build
cmake -DSYSTEM_INSTALL=ON \
- -DCMAKE_INSTALL_BINDIR=games \
- -DCMAKE_INSTALL_DATADIR=share/games \
- -DCMAKE_INSTALL_MANDIR=../man \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_BINDIR=bin \
+ -DCMAKE_INSTALL_DATADIR=share \
+ -DCMAKE_INSTALL_MANDIR=share/man \
..
make
}