summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHalosGhost2015-06-26 23:17:03 -0500
committerHalosGhost2015-06-26 23:17:03 -0500
commit7e570d00f5486af046b4f108114232f09bdf2d4f (patch)
tree420568c258a31dcb1b203d416abd731dc73c1a83
downloadaur-7e570d00f5486af046b4f108114232f09bdf2d4f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
-rw-r--r--lugaru.desktop12
-rw-r--r--lugaru.launcher3
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2c23b1f15e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lugaru
+ pkgdesc = A third-persion action game featuring a unique close-range combat system
+ pkgver = 1.0c
+ pkgrel = 3
+ url = http://www.wolfire.com/lugaru
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = openal
+ depends = sdl
+ source = lugaru-1.0c.zip::http://cdn.wolfire.com/games/lugaru/lugaru-linux-x86-1.0c.bin
+ source = lugaru.launcher
+ source = lugaru.desktop
+ sha256sums = ad330c9f5496a1fc54fb3640723420a80dfee9da47a71ef7a34a38848c885ade
+ sha256sums = c8a8bb5be74806f7c7aeef5839a7de549dbabb95edd4394063d7ad6572d88e04
+ sha256sums = 306df52e81c544ed8884f52d4c6392c9d0de8d82ea3c68a53d7d3d924d1780d9
+
+pkgname = lugaru
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06a9bf49aa52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+pkgname=lugaru
+pkgver=1.0c
+pkgrel=3
+pkgdesc="A third-persion action game featuring a unique close-range combat system"
+url="http://www.wolfire.com/lugaru"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('gcc-libs' 'openal' 'sdl')
+source=("${pkgname}-${pkgver}.zip::http://cdn.wolfire.com/games/${pkgname}/${pkgname}-linux-x86-${pkgver}.bin"
+ "${pkgname}.launcher"
+ "${pkgname}.desktop")
+sha256sums=('ad330c9f5496a1fc54fb3640723420a80dfee9da47a71ef7a34a38848c885ade'
+ 'c8a8bb5be74806f7c7aeef5839a7de549dbabb95edd4394063d7ad6572d88e04'
+ '306df52e81c544ed8884f52d4c6392c9d0de8d82ea3c68a53d7d3d924d1780d9')
+
+package() {
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a --no-preserve=ownership data/* "${pkgdir}/opt/${pkgname}"
+
+ install -Dm755 "${srcdir}/${pkgname}.launcher" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "data/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
diff --git a/lugaru.desktop b/lugaru.desktop
new file mode 100644
index 000000000000..97a4259d9058
--- /dev/null
+++ b/lugaru.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Lugaru
+GenericName=Lugaru
+Comment=Lugaru
+Exec=/usr/bin/lugaru
+Icon=/usr/share/pixmaps/lugaru.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Qt;KDE;GNOME;Application;Game;
+
diff --git a/lugaru.launcher b/lugaru.launcher
new file mode 100644
index 000000000000..67f67e308e6a
--- /dev/null
+++ b/lugaru.launcher
@@ -0,0 +1,3 @@
+#!/bin/bash
+(pushd /opt/lugaru
+./lugaru $*)