summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeanbon2016-12-26 19:45:31 +0100
committerJeanbon2016-12-27 11:01:39 +0100
commiteff1625c8663ddd1d778402842d92405dc608676 (patch)
treef2ebb1e038e5c3d5b0573866003be19515cb2f31
parent7e570d00f5486af046b4f108114232f09bdf2d4f (diff)
downloadaur-eff1625c8663ddd1d778402842d92405dc608676.tar.gz
Migrate to OSS version.
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD44
-rw-r--r--lugaru.desktop4
-rw-r--r--lugaru.launcher3
4 files changed, 46 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2c23b1f15e2..7f6f533886c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,26 @@
+# Generated by mksrcinfo v8
+# Mon Dec 26 19:00:30 UTC 2016
pkgbase = lugaru
- pkgdesc = A third-persion action game featuring a unique close-range combat system
- pkgver = 1.0c
- pkgrel = 3
- url = http://www.wolfire.com/lugaru
+ pkgdesc = A third-person action game featuring a unique close-range combat system
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://osslugaru.gitlab.io
arch = i686
arch = x86_64
- license = custom
- depends = gcc-libs
+ license = GPL
+ makedepends = cmake
+ depends = sdl2
+ depends = glu
+ depends = libjpeg-turbo
+ depends = libpng
depends = openal
- depends = sdl
- source = lugaru-1.0c.zip::http://cdn.wolfire.com/games/lugaru/lugaru-linux-x86-1.0c.bin
- source = lugaru.launcher
+ depends = libvorbis
+ depends = zlib
+ conflicts = lugaru-hg
+ source = lugaru-1.1.tar.bz2::https://gitlab.com/osslugaru/lugaru/repository/archive.tar.bz2?ref=1.1
source = lugaru.desktop
- sha256sums = ad330c9f5496a1fc54fb3640723420a80dfee9da47a71ef7a34a38848c885ade
- sha256sums = c8a8bb5be74806f7c7aeef5839a7de549dbabb95edd4394063d7ad6572d88e04
- sha256sums = 306df52e81c544ed8884f52d4c6392c9d0de8d82ea3c68a53d7d3d924d1780d9
+ sha256sums = 4372ef81494365f7227a72051960f3940acf8418006dbdb05c83d12232f481e7
+ sha256sums = c97bbd82701c07692f35fd86d0a4b4fdb2d5380a5672dde75617ae15389bfd15
pkgname = lugaru
diff --git a/PKGBUILD b/PKGBUILD
index 06a9bf49aa52..cda7bcd9b5bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
-# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
pkgname=lugaru
-pkgver=1.0c
-pkgrel=3
-pkgdesc="A third-persion action game featuring a unique close-range combat system"
-url="http://www.wolfire.com/lugaru"
-license=('custom')
+pkgver=1.1
+pkgrel=1
+pkgdesc="A third-person action game featuring a unique close-range combat system"
+url="https://osslugaru.gitlab.io"
+license=('GPL')
arch=('i686' 'x86_64')
-depends=('gcc-libs' 'openal' 'sdl')
-source=("${pkgname}-${pkgver}.zip::http://cdn.wolfire.com/games/${pkgname}/${pkgname}-linux-x86-${pkgver}.bin"
- "${pkgname}.launcher"
+depends=('sdl2' 'glu' 'libjpeg-turbo' 'libpng' 'openal' 'libvorbis' 'zlib')
+makedepends=('cmake')
+conflicts=('lugaru-hg')
+source=("${pkgname}-${pkgver}.tar.bz2::https://gitlab.com/osslugaru/lugaru/repository/archive.tar.bz2?ref=${pkgver}"
"${pkgname}.desktop")
-sha256sums=('ad330c9f5496a1fc54fb3640723420a80dfee9da47a71ef7a34a38848c885ade'
- 'c8a8bb5be74806f7c7aeef5839a7de549dbabb95edd4394063d7ad6572d88e04'
- '306df52e81c544ed8884f52d4c6392c9d0de8d82ea3c68a53d7d3d924d1780d9')
+sha256sums=('4372ef81494365f7227a72051960f3940acf8418006dbdb05c83d12232f481e7'
+ 'c97bbd82701c07692f35fd86d0a4b4fdb2d5380a5672dde75617ae15389bfd15')
+
+build() {
+ cd $srcdir/lugaru-1.1-53bbd7b11ba7558692b00d936d3103750fcb430b/
+ mkdir build
+ cd build
+ cmake -DSYSTEM_INSTALL=ON \
+ -DCMAKE_INSTALL_BINDIR=games \
+ -DCMAKE_INSTALL_DATADIR=share/games \
+ -DCMAKE_INSTALL_MANDIR=../man \
+ ..
+ make
+}
package() {
- install -d "${pkgdir}/opt/${pkgname}"
- cp -a --no-preserve=ownership data/* "${pkgdir}/opt/${pkgname}"
-
- install -Dm755 "${srcdir}/${pkgname}.launcher" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "data/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ cd $srcdir/lugaru-1.1-53bbd7b11ba7558692b00d936d3103750fcb430b/build
+ make DESTDIR="$pkgdir/" install
+
}
diff --git a/lugaru.desktop b/lugaru.desktop
index 97a4259d9058..c3da4c258984 100644
--- a/lugaru.desktop
+++ b/lugaru.desktop
@@ -3,8 +3,8 @@ Encoding=UTF-8
Name=Lugaru
GenericName=Lugaru
Comment=Lugaru
-Exec=/usr/bin/lugaru
-Icon=/usr/share/pixmaps/lugaru.png
+Exec=/usr/local/games/lugaru
+Icon=/usr/local/share/icons/hicolor/128x128/apps/lugaru.png
StartupNotify=true
Terminal=false
Type=Application
diff --git a/lugaru.launcher b/lugaru.launcher
deleted file mode 100644
index 67f67e308e6a..000000000000
--- a/lugaru.launcher
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-(pushd /opt/lugaru
-./lugaru $*)