summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Hirzel2022-12-09 15:50:35 -0500
committerAlex Hirzel2022-12-09 15:50:35 -0500
commit09c424124639d32d816d41ff2a4b7bf79328846b (patch)
tree74ad528977b144fe826748974f28c4f5945bc21f
parent6b92681001b6751d7a32530b9103ab702a05277b (diff)
downloadaur-09c424124639d32d816d41ff2a4b7bf79328846b.tar.gz
clean up dependencies where possible
-rw-r--r--.SRCINFO59
-rw-r--r--.gitignore23
-rw-r--r--PKGBUILD36
-rw-r--r--abseil-cpp.patch11
-rw-r--r--assimp.patch31
-rw-r--r--pybind11.patch13
6 files changed, 136 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ab8531234a3..f4bddd9d7d9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = luisarender-git
pkgdesc = High-Performance Rendering Framework on Stream Architectures
- pkgver = de7818a7
+ pkgver = 1381f5ab
pkgrel = 1
url = https://luisa-render.com/
arch = x86_64
@@ -8,13 +8,15 @@ pkgbase = luisarender-git
makedepends = clang
makedepends = git
makedepends = cmake
- depends = gcc-libs
+ depends = abseil-cpp
+ depends = assimp
depends = cuda
+ depends = embree
depends = glfw-wayland
+ depends = tbb
source = git+https://github.com/LuisaGroup/LuisaRender.git
source = git+https://github.com/LuisaGroup/LuisaCompute.git
source = git+https://github.com/jarro2783/cxxopts.git
- source = git+https://github.com/assimp/assimp.git
source = git+https://github.com/fastfloat/fast_float.git
source = git+https://github.com/syoyo/tinyexr.git
source = git+https://github.com/Cyan4973/xxHash.git
@@ -26,36 +28,37 @@ pkgbase = luisarender-git
source = git+https://github.com/ocornut/imgui.git
source = git+https://github.com/LuisaGroup/EASTL.git
source = git+https://github.com/jothepro/doxygen-awesome-css.git
- source = git+https://github.com/pybind/pybind11
- source = git+https://github.com/abseil/abseil-cpp.git
source = git+https://github.com/KhronosGroup/SPIRV-Headers
source = git+https://github.com/KhronosGroup/SPIRV-Tools.git
source = git+https://github.com/KhronosGroup/glslang.git
source = git+https://github.com/google/shaderc.git
source = git+https://github.com/LuisaGroup/EABase.git
source = git+https://github.com/microsoft/mimalloc.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = assimp.patch
+ source = abseil-cpp.patch
+ source = pybind11.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 822638ea7608bf42fdfd7f04d4453c5413c7cb673296415fc82dc110fc1f97a3
+ sha256sums = 0fb87b700d7e657836d69aca7f114d8bfaaf7843b0c04c05cb4d3f2cb2a99ba6
+ sha256sums = a1bd3301ed9aaa7cb35acf14afe430db3edd1523324fa6498776e60e80c4cf14
pkgname = luisarender-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..83fd234297a4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,23 @@
+pkg/
+src/
+
+asio/
+cxxopts/
+doxygen-awesome-css/
+EABase/
+EASTL/
+fast_float/
+glfw/
+glslang/
+imgui/
+json/
+LuisaCompute/
+LuisaRender/
+mimalloc/
+shaderc/
+spdlog/
+SPIRV-Headers/
+SPIRV-Tools/
+stb/
+tinyexr/
+xxHash/
diff --git a/PKGBUILD b/PKGBUILD
index 07094cf707c6..798bcbcfd5dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Alex Hirzel <alex at hirzel period us>
pkgname=luisarender-git
-pkgver=de7818a7
+pkgver=1381f5ab
pkgrel=1
pkgdesc="High-Performance Rendering Framework on Stream Architectures"
arch=('x86_64')
url="https://luisa-render.com/"
license=('BSD')
-depends=('gcc-libs' 'cuda' 'glfw-wayland')
+depends=('abseil-cpp' 'assimp' 'cuda' 'embree' 'glfw-wayland' 'tbb')
makedepends=('clang' 'git' 'cmake')
source=(
'git+https://github.com/LuisaGroup/LuisaRender.git'
'git+https://github.com/LuisaGroup/LuisaCompute.git'
'git+https://github.com/jarro2783/cxxopts.git'
- 'git+https://github.com/assimp/assimp.git'
'git+https://github.com/fastfloat/fast_float.git'
'git+https://github.com/syoyo/tinyexr.git'
@@ -27,8 +26,6 @@ source=(
'git+https://github.com/ocornut/imgui.git'
'git+https://github.com/LuisaGroup/EASTL.git'
'git+https://github.com/jothepro/doxygen-awesome-css.git'
- 'git+https://github.com/pybind/pybind11'
- 'git+https://github.com/abseil/abseil-cpp.git'
'git+https://github.com/KhronosGroup/SPIRV-Headers'
'git+https://github.com/KhronosGroup/SPIRV-Tools.git'
'git+https://github.com/KhronosGroup/glslang.git'
@@ -37,12 +34,20 @@ source=(
# submodules within compute
'git+https://github.com/LuisaGroup/EABase.git'
'git+https://github.com/microsoft/mimalloc.git'
+
+ 'assimp.patch'
+ 'abseil-cpp.patch'
+ 'pybind11.patch'
)
-md5sums=(
+sha256sums=(
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+
+ '822638ea7608bf42fdfd7f04d4453c5413c7cb673296415fc82dc110fc1f97a3'
+ '0fb87b700d7e657836d69aca7f114d8bfaaf7843b0c04c05cb4d3f2cb2a99ba6'
+ 'a1bd3301ed9aaa7cb35acf14afe430db3edd1523324fa6498776e60e80c4cf14'
)
pkgver() {
@@ -69,14 +74,12 @@ prepare() {
"EABase src/compute/src/ext/EASTL/packages/EABase" \
"mimalloc src/compute/src/ext/EASTL/packages/mimalloc" \
"doxygen-awesome-css src/compute/src/ext/doxygen-awesome-css" \
- "pybi src/compute/src/ext/pybind11" \
"abseil-cpp src/compute/src/ext/abseil-cpp" \
"SPIRV-Hea src/compute/src/ext/SPIRV-Headers" \
"SPIRV-Tools src/compute/src/ext/SPIRV-Tools" \
"glslang src/compute/src/ext/glslang" \
"shaderc src/compute/src/ext/shaderc" \
"cxxopts src/ext/cxxopts" \
- "assimp src/ext/assimp" \
"fast_float src/ext/fast_float" \
"tinyexr src/ext/tinyexr" \
; do
@@ -96,6 +99,21 @@ prepare() {
git -c protocol.file.allow=always submodule update --init $submodule_path_within_repo
popd > /dev/null
done
+
+ # use system assimp
+ pushd "$srcdir/LuisaRender" > /dev/null
+ git restore . # in case it was already applied
+ git apply -v "$srcdir/assimp.patch"
+ rm -rf ext/assimp
+ popd > /dev/null
+
+ # use system abseil-cpp and pybind11
+ pushd "$srcdir/LuisaRender/src/compute" > /dev/null
+ git restore . # in case it was already applied
+ git apply -v "$srcdir/abseil-cpp.patch"
+ git apply -v "$srcdir/pybind11.patch"
+ rm -rf ext/abseil-cpp ext/pybi
+ popd > /dev/null
}
build() {
diff --git a/abseil-cpp.patch b/abseil-cpp.patch
new file mode 100644
index 000000000000..7a495f0fa89a
--- /dev/null
+++ b/abseil-cpp.patch
@@ -0,0 +1,11 @@
+diff --git a/src/ext/CMakeLists.txt b/src/ext/CMakeLists.txt
+index 13df36e2..61f84c14 100644
+--- a/src/ext/CMakeLists.txt
++++ b/src/ext/CMakeLists.txt
+@@ -160,5 +160,5 @@ if (WIN32 AND NOT MINGW AND NOT MSYS)
+ endif ()
+
+ set(ABSL_PROPAGATE_CXX_STD ON CACHE BOOL "" FORCE)
+-add_subdirectory(abseil-cpp)
++find_package(absl CONFIG REQUIRED)
+ target_link_libraries(luisa-compute-ext PUBLIC absl::base absl::flat_hash_map)
diff --git a/assimp.patch b/assimp.patch
new file mode 100644
index 000000000000..c3ef1f6543dd
--- /dev/null
+++ b/assimp.patch
@@ -0,0 +1,31 @@
+diff --git a/src/ext/CMakeLists.txt b/src/ext/CMakeLists.txt
+index 6b2690eb..bfdf5091 100644
+--- a/src/ext/CMakeLists.txt
++++ b/src/ext/CMakeLists.txt
+@@ -7,25 +7,7 @@ add_library(fast_float INTERFACE)
+ target_include_directories(fast_float INTERFACE fast_float/include)
+ target_link_libraries(luisa-render-ext INTERFACE fast_float)
+
+-#find_package(assimp CONFIG)
+-if (NOT assimp_FOUND)
+- set(ASSIMP_BUILD_ZLIB ON CACHE BOOL "" FORCE)
+- set(ASSIMP_BUILD_ASSIMP_TOOLS OFF CACHE BOOL "" FORCE)
+- set(ASSIMP_BUILD_TESTS OFF CACHE BOOL "" FORCE)
+- set(ASSIMP_INSTALL OFF CACHE BOOL "" FORCE)
+- set(ASSIMP_INJECT_DEBUG_POSTFIX OFF CACHE BOOL "" FORCE)
+- set(ASSIMP_NO_EXPORT ON CACHE BOOL "" FORCE)
+- set(ASSIMP_BUILD_ALL_IMPORTERS_BY_DEFAULT ON CACHE BOOL "" FORCE)
+- add_subdirectory(assimp)
+- set_target_properties(assimp PROPERTIES UNITY_BUILD OFF)
+- if (UNIX AND NOT APPLE)
+- target_compile_definitions(assimp PRIVATE USE_FILE32API=1)
+- endif ()
+- if (CMAKE_CXX_COMPILER_ID MATCHES "Clang" AND
+- CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 15.0)
+- target_compile_options(assimp PRIVATE -Wno-deprecated-non-prototype)
+- endif ()
+-endif ()
++find_package(assimp CONFIG)
+ target_link_libraries(luisa-render-ext INTERFACE assimp::assimp)
+
+ set(TINYEXR_BUILD_SAMPLE OFF CACHE BOOL "" FORCE)
diff --git a/pybind11.patch b/pybind11.patch
new file mode 100644
index 000000000000..33c5e2965ad6
--- /dev/null
+++ b/pybind11.patch
@@ -0,0 +1,13 @@
+diff --git a/src/ext/CMakeLists.txt b/src/ext/CMakeLists.txt
+index d90636a9..8197f0d3 100644
+--- a/src/ext/CMakeLists.txt
++++ b/src/ext/CMakeLists.txt
+@@ -80,7 +80,7 @@ add_subdirectory(EASTL)
+ target_link_libraries(luisa-compute-ext PUBLIC EASTL)
+
+ if (LUISA_COMPUTE_ENABLE_PYTHON)
+- add_subdirectory(pybind11)
++ find_package(pybind11 REQUIRED)
+ endif ()
+
+ if (LUISA_COMPUTE_ENABLE_ISPC OR LUISA_COMPUTE_ENABLE_LLVM)