summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2017-03-14 13:26:48 -0400
committerCorey Hinshaw2017-03-14 13:26:48 -0400
commit4247061b6b95635fedeb7f7175e1774edd2bbec5 (patch)
tree74b0b0c6f6d2fcfe86e08e5923f45a4138ce8277
parentf968a74dbf4aae05b72da89949c8d4605d3020e5 (diff)
downloadaur-4247061b6b95635fedeb7f7175e1774edd2bbec5.tar.gz
Fix STDERR redirection issue for invalid options
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xluks-tpm2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54d2a2a1bea2..6e11abd388b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = luks-tpm
pkgdesc = Utility to manage LUKS keyfiles sealed by the TPM
- pkgver = 0.2.0
+ pkgver = 0.2.1
pkgrel = 1
url = https://github.com/electrickite/luks-tpm
arch = any
@@ -11,7 +11,7 @@ pkgbase = luks-tpm
depends = coreutils
depends = util-linux
source = luks-tpm
- sha256sums = c3e1369c91aac6d5bcf6efd1d9b506abd2cf6ddf35da1381887649206b51eef8
+ sha256sums = 45e4009da6ff8810cb38f4178a23023c0111563d2a500292459c58d6dd5e058c
pkgname = luks-tpm
diff --git a/PKGBUILD b/PKGBUILD
index 4eb0fdbef70e..0e043eaca9db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Corey Hinshaw <coreyhinshaw@gmail.com>
pkgname=luks-tpm
-pkgver=0.2.0
+pkgver=0.2.1
pkgrel=1
pkgdesc="Utility to manage LUKS keyfiles sealed by the TPM"
arch=('any')
@@ -10,7 +10,7 @@ license=('GPL')
depends=('tpm-tools' 'trousers' 'cryptsetup' 'coreutils' 'util-linux')
source=('luks-tpm')
-sha256sums=('c3e1369c91aac6d5bcf6efd1d9b506abd2cf6ddf35da1381887649206b51eef8')
+sha256sums=('45e4009da6ff8810cb38f4178a23023c0111563d2a500292459c58d6dd5e058c')
package() {
install -Dm755 luks-tpm "${pkgdir}/usr/bin/luks-tpm"
diff --git a/luks-tpm b/luks-tpm
index 9bc10302968a..5b9b5e3e25fc 100755
--- a/luks-tpm
+++ b/luks-tpm
@@ -173,7 +173,7 @@ while getopts ":hm:k:t:r:p:z" opt; do
;;
\?)
echo "Invalid option: -$OPTARG" >&2
- usage >2&
+ usage >&2
exit 1
;;
:)