summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2022-07-31 22:14:26 -0400
committerCorey Hinshaw2022-07-31 22:14:26 -0400
commit128f1a20b29d949ae9dc447b73e5421da383ae26 (patch)
tree595afc965222ed9d4fd92c98c52b41df16094437
parentd21df45f8fa8c7bd30e7d1b1de537cb2839683e4 (diff)
downloadaur-128f1a20b29d949ae9dc447b73e5421da383ae26.tar.gz
Update to version 2.1.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--luks-tpm2.hook21
3 files changed, 24 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84d7de698a54..57ffa46b9b90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = luks-tpm2
pkgdesc = Utility to manage LUKS keys sealed by a TPM 2.0
- pkgver = 2.1.1
+ pkgver = 2.1.2
pkgrel = 2
url = https://github.com/electrickite/luks-tpm2
install = luks-tpm2.install
@@ -14,9 +14,9 @@ pkgbase = luks-tpm2
depends = grep
optdepends = tpm_futurepcr: To pre-compute kernel PCR values
backup = etc/default/luks-tpm2
- source = https://github.com/electrickite/luks-tpm2/archive/2.1.1.tar.gz
+ source = https://github.com/electrickite/luks-tpm2/archive/2.1.2.tar.gz
source = luks-tpm2.hook
- sha1sums = 3c446f7a8796abc9552c7402c03343f7a52e20f9
- sha1sums = e4b308b4e789d0ca9f1659b22ad0cd9193749558
+ sha256sums = 2b0ddcca8de05f093754ccf2665f675af9ddf6ad55f17e07727db107d7666398
+ sha256sums = 4ee1068d53882c89e4130d972a549cb594fbca0ec21b38a2a4786986f177962b
pkgname = luks-tpm2
diff --git a/PKGBUILD b/PKGBUILD
index 0de3a7ed3984..4d84e88642db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=luks-tpm2
-pkgver=2.1.1
+pkgver=2.1.2
pkgrel=2
pkgdesc="Utility to manage LUKS keys sealed by a TPM 2.0"
arch=('any')
@@ -19,8 +19,8 @@ optdepends=('tpm_futurepcr: To pre-compute kernel PCR values')
source=("https://github.com/electrickite/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.hook")
-sha1sums=('3c446f7a8796abc9552c7402c03343f7a52e20f9'
- 'e4b308b4e789d0ca9f1659b22ad0cd9193749558')
+sha256sums=('2b0ddcca8de05f093754ccf2665f675af9ddf6ad55f17e07727db107d7666398'
+ '4ee1068d53882c89e4130d972a549cb594fbca0ec21b38a2a4786986f177962b')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/luks-tpm2.hook b/luks-tpm2.hook
index 5729678d20ed..4d50e6a9260f 100644
--- a/luks-tpm2.hook
+++ b/luks-tpm2.hook
@@ -1,14 +1,27 @@
[Trigger]
Operation = Install
Operation = Upgrade
-Operation = Remove
Type = Path
-Target = boot/vmlinuz-*
-Target = boot/intel-ucode.img
-Target = usr/lib/initcpio/*
+Target = usr/lib/modules/*/vmlinuz
Target = usr/lib/systemd/boot/efi/linux*.efi.stub
Target = usr/share/refind/refind_x64.efi
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Type = Path
+Target = usr/lib/initcpio/*
+Target = usr/src/*/dkms.conf
+
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Type = Package
+Target = intel-ucode
+Target = amd-ucode
+
[Action]
Description = Adding temporary LUKS TPM key...
When = PostTransaction