summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2018-12-10 00:16:24 +0100
committerJonas Witschel2018-12-10 00:16:24 +0100
commit5ed856bfd449444d1c1ded96db968400961ec3ec (patch)
tree55150ac9229fdafe494db0a7cbd39feb8233215c
parent3aac8461237528b5a435d2f05e2c8a96c1077f4c (diff)
downloadaur-5ed856bfd449444d1c1ded96db968400961ec3ec.tar.gz
upgpkg: luksmeta-git 9.r0.3e3cba3-2
Fix upstream issue #6
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--Relax-content-tests-in-test-suite.patch148
3 files changed, 161 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcf028205d2d..231881a74ec8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luksmeta-git
pkgdesc = Library for storing metadata in the LUKSv1 header
pkgver = 9.r0.3e3cba3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/latchset/luksmeta
arch = x86_64
license = LGPL
@@ -11,7 +11,9 @@ pkgbase = luksmeta-git
provides = luksmeta
conflicts = luksmeta
source = git+https://github.com/latchset/luksmeta.git
+ source = Relax-content-tests-in-test-suite.patch
sha512sums = SKIP
+ sha512sums = 145f6ceb7bad2090067c5e994bb0f89ce6388cc3c5b3e27a48704c3ae33615a81dcf309b54aa0d0004782890f9260560a24f274d442b3a397a352f5bac5b638e
pkgname = luksmeta-git
diff --git a/PKGBUILD b/PKGBUILD
index c4a4cbee066a..4976406755b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
pkgname=luksmeta-git
pkgver=9.r0.3e3cba3
-pkgrel=1
+pkgrel=2
pkgdesc='Library for storing metadata in the LUKSv1 header'
arch=('x86_64')
url='https://github.com/latchset/luksmeta'
@@ -10,8 +10,10 @@ depends=('cryptsetup')
makedepends=('git' 'asciidoc')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+$url.git")
-sha512sums=('SKIP')
+source=("git+$url.git"
+ 'Relax-content-tests-in-test-suite.patch')
+sha512sums=('SKIP'
+ '145f6ceb7bad2090067c5e994bb0f89ce6388cc3c5b3e27a48704c3ae33615a81dcf309b54aa0d0004782890f9260560a24f274d442b3a397a352f5bac5b638e')
pkgver() {
cd "${pkgname%-git}"
@@ -20,7 +22,9 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- autoreconf -if
+ # https://github.com/latchset/luksmeta/issues/6
+ patch --strip=1 --input="$srcdir/Relax-content-tests-in-test-suite.patch"
+ autoreconf --install --force
}
build() {
@@ -31,10 +35,10 @@ build() {
check() {
cd "${pkgname%-git}"
- make -k check
+ make check
}
package() {
cd "${pkgname%-git}"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
}
diff --git a/Relax-content-tests-in-test-suite.patch b/Relax-content-tests-in-test-suite.patch
new file mode 100644
index 000000000000..a1e451036888
--- /dev/null
+++ b/Relax-content-tests-in-test-suite.patch
@@ -0,0 +1,148 @@
+From 334430e562a196bc1f0bad051103ca5dca31c266 Mon Sep 17 00:00:00 2001
+From: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
+Date: Sun, 9 Dec 2018 22:31:22 +0000
+Subject: [PATCH] Relax content tests in test suite
+
+Starting with version 2.0.5, cryptset wipes the full LUKS header
+and fills unused sections with random data, this was introduced
+in commit
+
+commit c2bce3e93ecee41f661b589ee28f112eb538259e
+Author: Milan Broz <gmazyland@gmail.com>
+Date: Sun Oct 14 13:11:50 2018 +0200
+
+ Wipe full header areas (including unused) during LUKS format.
+
+While this is the right thing to do, it breaks luksmeta tests. So
+relax them.
+---
+ test-lm-assumptions.c | 3 ++-
+ test-lm-big.c | 4 ++--
+ test-lm-init.c | 4 ++--
+ test-lm-one.c | 4 ++--
+ test-lm-two.c | 8 ++++----
+ 5 files changed, 12 insertions(+), 11 deletions(-)
+
+diff --git a/test-lm-assumptions.c b/test-lm-assumptions.c
+index d9ff20b..b4f293f 100644
+--- a/test-lm-assumptions.c
++++ b/test-lm-assumptions.c
+@@ -28,7 +28,8 @@ main(int argc, char *argv[])
+ /* Test the layout state. */
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- END(1024), /* Rest of the file */
++ { 1024, 3072, true }, /* Keyslot Area */
++ { 0, 0 },
+ }));
+
+ unlink(filename);
+diff --git a/test-lm-big.c b/test-lm-big.c
+index 6098e59..eb94d3b 100644
+--- a/test-lm-big.c
++++ b/test-lm-big.c
+@@ -111,7 +111,7 @@ main(int argc, char *argv[])
+
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ { offset + 4096, 4096 }, /* luksmeta slot 0 */
+ { offset + 8192, 4096 }, /* luksmeta slot 0 (cont) */
+@@ -127,7 +127,7 @@ main(int argc, char *argv[])
+
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ END(offset + 4096), /* Rest of the file */
+ }));
+diff --git a/test-lm-init.c b/test-lm-init.c
+index 2a6cb45..b16d597 100644
+--- a/test-lm-init.c
++++ b/test-lm-init.c
+@@ -57,7 +57,7 @@ main(int argc, char *argv[])
+ /* Test the layout state. */
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ END(offset + 4096), /* Rest of the file */
+ }));
+@@ -106,7 +106,7 @@ main(int argc, char *argv[])
+ assert(luksmeta_test(cd) == -ENOENT);
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ END(offset), /* Rest of the file */
+ }));
+
+diff --git a/test-lm-one.c b/test-lm-one.c
+index 8deb70a..18613e0 100644
+--- a/test-lm-one.c
++++ b/test-lm-one.c
+@@ -49,7 +49,7 @@ main(int argc, char *argv[])
+ /* Test the layout state. */
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ { offset + 4096, 4096 }, /* luksmeta slot 0 */
+ END(offset + 8192), /* Rest of the file */
+@@ -68,7 +68,7 @@ main(int argc, char *argv[])
+ /* Test the layout state. */
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ END(offset + 4096), /* Rest of the file */
+ }));
+diff --git a/test-lm-two.c b/test-lm-two.c
+index 78fea5b..9f0b1c5 100644
+--- a/test-lm-two.c
++++ b/test-lm-two.c
+@@ -53,7 +53,7 @@ main(int argc, char *argv[])
+
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ { offset + 4096, 4096 }, /* luksmeta slot 0 */
+ END(offset + 8192), /* Rest of the file */
+@@ -70,7 +70,7 @@ main(int argc, char *argv[])
+
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ { offset + 4096, 4096 }, /* luksmeta slot 0 */
+ { offset + 8192, 4096 }, /* luksmeta slot 1 */
+@@ -88,7 +88,7 @@ main(int argc, char *argv[])
+ assert(luksmeta_wipe(cd, 0, UUID0) == 0);
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ { offset + 4096, 4096, true }, /* luksmeta slot 0 */
+ { offset + 8192, 4096 }, /* luksmeta slot 1 */
+@@ -99,7 +99,7 @@ main(int argc, char *argv[])
+ assert(luksmeta_wipe(cd, 1, UUID1) == 0);
+ assert(test_layout((range_t[]) {
+ { 0, 1024 }, /* LUKS header */
+- { 1024, offset - 1024, true }, /* Keyslot Area */
++ { 1024, 3072, true }, /* Keyslot Area */
+ { offset, 4096 }, /* luksmeta header */
+ END(offset + 4096), /* Rest of the file */
+ }));
+--
+2.19.2
+