summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-04-08 19:23:51 +0200
committerMichael Straube2017-04-08 19:23:51 +0200
commit7fa52e180e4dbbd2bd4ae950e2a9fd62f9c72728 (patch)
tree30d094dccdba48965de4d349e5d7b72114c51998
parent0ce3c12d7fbde75bdc619b5e6cae30f6726bae82 (diff)
downloadaur-7fa52e180e4dbbd2bd4ae950e2a9fd62f9c72728.tar.gz
2.9-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 23 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7508664dad0..02fdf63db813 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = lumail2
pkgdesc = Console-based mail-client with integrated Lua scripting support
- pkgver = 2.8
- pkgrel = 2
+ pkgver = 2.9
+ pkgrel = 1
url = https://lumail.org
arch = i686
arch = x86_64
license = GPL
- makedepends = gcc
depends = lua
depends = gmime
depends = file
- depends = ncurses
- depends = pcre
- provides = lumail2
- source = https://github.com/lumail/lumail2/archive/release-2.8.tar.gz
- source = Makefile.replace
- md5sums = SKIP
- md5sums = SKIP
+ depends = perl
+ source = https://lumail.org/download/lumail-2.9.tar.gz
+ source = https://lumail.org/download/lumail-2.9.tar.gz.asc
+ validpgpkeys = D516C42B1D0E3F854CAB97231909D4080C626242
+ sha256sums = 4c0b2a6c0c8958fad261ca1a3ab1ab14822e484182821c1a23db0c16172dd1e6
+ sha256sums = SKIP
pkgname = lumail2
diff --git a/PKGBUILD b/PKGBUILD
index 977a33295172..2c59297c9430 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,27 @@
pkgname=lumail2
-pkgver=2.8
-pkgrel=2
+pkgver=2.9
+pkgrel=1
pkgdesc="Console-based mail-client with integrated Lua scripting support"
arch=('i686' 'x86_64')
url="https://lumail.org"
license=('GPL')
-depends=('lua' 'gmime' 'file' 'ncurses' 'pcre')
-makedepends=('gcc')
-provides=('lumail2')
-source=(\
- "https://github.com/lumail/lumail2/archive/release-${pkgver}.tar.gz" \
- "Makefile.replace")
-md5sums=(SKIP SKIP)
-_src="${pkgname}-release-${pkgver}"
+depends=('lua' 'gmime' 'file' 'perl')
+source=("https://lumail.org/download/lumail-$pkgver.tar.gz"{,.asc})
+validpgpkeys=('D516C42B1D0E3F854CAB97231909D4080C626242') # Steve Kemp
+sha256sums=('4c0b2a6c0c8958fad261ca1a3ab1ab14822e484182821c1a23db0c16172dd1e6'
+ 'SKIP')
-prepare(){
- # Remove in next lumail release; has been fixed upstream.
- cp Makefile.replace "$_src"/Makefile
+build() {
+ cd lumail-$pkgver
+ make LUA_VERSION=5.3 LVER=lua
}
-build() {
- cd "$_src"
- make LUA_VERSION=5.3 LVER=lua
+check() {
+ cd lumail-$pkgver
+ ./lumail2 --test
}
package() {
- cd "$_src"
- make DESTDIR="$pkgdir/" install
+ cd lumail-$pkgver
+ make DESTDIR="$pkgdir" install
}